Mosquitto connection error

Hi all,

After some advice of members on here I have installed Debian 10 on a desktop pc and am using it to run HomeAssistant after some help I have it up and running and working fine with the exception of Mosquitto.

I have it installed following this guide

but it doesn’t work. When running a test in terminal I get an error message
Connection Refused : not authorised.

I have read what feels like 100s of threads to try and find a solution and I am at a loss.

Please can anyone help. This is the last bit I need to sort then I can swap from using my pi3 to the pc.
One other thing I have about a weeks experience with linux so please be gentle.

Not authorized indicates an issue with the username and/or password you used in your test. Get that working first before proceeding.

Thanks for the reply.

I suspect you are right.

The test message I was using did not have the password in it. When including the the password I can successfully publish and receive messages in 2 terminal windows. Progress.

Now the next issue. My mqtt devices still don’t work.

I have a Sonoff flashed with Tasmota. I have changed the config to the new ip address and the user and password are what is set up in Mosquitto. I the console it shows the device as connected but does not show up in homeassistant.

Could my problem be the link between Mosquitto and HA, rather than the devices connecting to the broker?

Is there a terminal command to see what devices are connected via mqtt?

I believe Mosquitto has some logs. I have only tested mQTT briefly.

What user name did you use DONT USE homeassistant

The user name I used when setting up mosquitto is ‘mqtt’ this is the name of the user I have set up in HA

If I run

sudo service mosquitto stop

then it shows connection lost in the tasmota console, then it reconnects when running the start command which to me is pointing a possible Homeassistant issue but thats a guess of course

could there be issue with this config entry

discovery: true
discovery_prefix: homeassistant
port: 1883
client_id: home-assistant-1
keepalive: 60
username: mqtt
password: ***********