Mosquitto mqtt not working after Raspbian RP 3 atp-get upgrade

After I upgrade Raspbian on my RP3 none of my Mosquitto MQTT server related items lights, switches or Own Tracks work. Al I get is a message stating MQTT is configured incorrectly. When I check my config everything is ok. Luckly I had a complete backup to bring my system back. I have tried the same apt-get upgrade several times with the same results.

I observed the same thing tonight where my MQTT sensors were not being picked up by HA after an update/upgrade. Restart of Hass and they all started to work again.

I did notice an update to mosquitto during the update so I guess HA just needed a restart.

Did you try a restart of Hass first ?

Mosquitto won’t start on on boot after the upgrade. To enable it on boot use the following command:

sudo systemctl enable mosquitto.service


sudo systemctl start mosquitto.service

to check if it is running:

sudo systemctl status mosquitto.service
1 Like

is it always like this, or will it be fixed to reboot automatically after and upgrade ?

It should be fixed after running the commands I posted. I haven’t created a bug yet, but it seems the packager left something out.

yes it is fixed, thank you very much by the way.

My question was : will it always be like this ? after all new upgrade ?

This is the first time it has happened. After every other apt-get upgrade I reboot manually sudo reboot or sudo shutdown -r. I am not sure how to boot automatically after a upgrade. My HA always restarts automatically after I do a reboot of the PI.


Is this something new with this upgarde? I have did apt-get upgrade many times and this is the first time this has happened. I will give it a try.


Yes several times both reboot the PI and restarting HA and still getting the same results MQTT config incorrect.

Cariboo solution worked for me… I assume this issue will get fixed before the 0.46 upgrade.

Worked for me also!! Thanks for the help.

This is nothing to do with Hass, there was an update to mosquitto and when you updated your pi you updated mosquitto as well.

Mosquitto is separate to Hass, cariboo’s commands just restarted mosquitto for you after the update.

1 Like

I can confirm that this fixed my issues starting up Mosquitto automatically after a reboot

1 Like

0.47.1, same errors, all my mqtt devices are configured incorrect, so mosquitto not running after aio install.
No prob in the 0.46.x versions but…