Motion Blinds AccessToken error

Hello, i was using motion blinds integration successfully for a while now, but had to reconfigure everything when my bridge lost the wifi connection.
I also did a firmware upgrade of the bridge.
I then deleted the old integration and tried to install it from scratch, but i am unable to get it working:

Received actionResult: 'AccessToken error

I checked the access token twice, even installed the app on another phone and tried to retrieve the token from there.

Is this a maybe known bug with the newest firmware of the bridge?

Full log:

Logger: motionblinds.motion_blinds
Source: /usr/local/lib/python3.8/site-packages/motionblinds/
First occurred: 21:18:51 (4 occurrences)
Last logged: 22:50:49

Received actionResult: 'AccessToken error', when sending message: '{'msgType': 'ReadDevice', 'mac': '8caab5ca918b', 'deviceType': '02000001', 'msgID': '20210517191851610'}'
Received actionResult: 'AccessToken error', when sending message: '{'msgType': 'ReadDevice', 'mac': '8caab5ca918b', 'deviceType': '02000001', 'msgID': '20210517192706570'}'
Received actionResult: 'AccessToken error', when sending message: '{'msgType': 'ReadDevice', 'mac': '8caab5ca918b', 'deviceType': '02000001', 'msgID': '20210517193223390'}'
Received actionResult: 'AccessToken error', when sending message: '{'msgType': 'ReadDevice', 'mac': '8caab5ca918b', 'deviceType': '02000001', 'msgID': '20210517205049081'}'
1 Like

Having the same issue. Were you able to resolve this?

Yes this was a bug in the firmware of the bridge.
This bug has been fixed in later versions of the bridge and also in later versions of HomeAssistant attempts were made to cercumvent this bug.

Are you still experaincing these errors or any other issues on the latest firmware of the bridge and the latest HomeAssistant version?

I started getting this error after one of the last few updates. I’m currently at 2022.8.1. Reading the blinds entities works but I can’t control them. As suggested by the docs, I have disabled the “wait for multicast push on update” checkbox but still to no avail. Both bridge and hassio are up-to-date.

I can’t get over the fact the controlling the blinds works from Google Home. Is there anything else I can check to debug this issue?

Update: I also see this error in the logs: “Could not find working interface for Motion Blinds host, using interface ‘any’”. It sounds like a warning rather than a real error though.

1 Like

I have the same error and would appreciate any help… I’m running Home Assistant 2023.9.2 and the error I’m receiving is

ERROR (SyncWorker_5) [motionblinds.motion_blinds] Received actionResult: 'AccessToken error', when sending message:

I had this working for weeks then started getting this error and no longer working

I had the same issue but not anymore. One of the two things I did below helped to resolve this:

  • Reset the Motion Blinds integration (as in delete and and add it again).
  • Connect the Motion Blinds gateway to the hacs access point (the one from Add-ons).

Hi Alex, Thanks for the Assistance…

  • I have deleted/installed the integration several attempts and no luck there

  • Im not quite following you on the connection of the Motion Blinds gateway… Also not sure what the hacs access point is, I do use hacs so that’s installed

Would appreciate any further help you may provide

You can turn your raspi into a WIFI access point, only if the former has a wireless adapter and it’s not in use. In my case I connect my raspi via ethernet cable so I use the WIFI AP to:

  • make sure multicast for motion blinds gateway works which is not guaranteed if you using your wifi router
  • have static IPs for some tuya devices which is needed for localtuya

The way to get the wifi ap working is Settings → Addons → Access Point. Here’s an excerpt from my config:

ssid: HomeAssistant
wpa_passphrase: [enter your password here]
channel: 5
interface: wlan0
hide_ssid: "0"
dhcp: 1
allow_mac_addresses: []
deny_mac_addresses: []
debug: 1
hostapd_config_override: []
client_internet_access: 1
client_dns_override: []
  - dhcp-host=50:02:91:[rest of your blinds gateway mac],blinds,

I know it’s quite some work. Give it a try and let’s if it helps with your blinds.

Wow, a little over my head but I’m up for the challenge
My raspi is using Ethernet so the wifi is free. As for multicast not sure how I check that