MotionEye camera proxy stream not working


In Home Assistant, I’ve installed and configured the MotionEye addon and its integration. I added a remote MotionEye camera running on a Raspberry Pi Zero in the MotionEye UI.

In the MotionEye UI I can see my remote camera fine, and also when added to lovelace with a picture entity card I can see updated thumbnails. However when I click it, the camera will not stream, it displays an broken image with alt text “Preview of the xxx camera”.

When I right click the broken image to view the link address ([token]) it leads to a “502: Bad Gateway”

Enabled the debug logging as instructed here but couldn’t see more info why the camera proxy stream isn’t working. Any way to debug this further?

I’m using a reverse proxy for accessing my HA install but when I tried it with the local ip (e.g.[token]) it also didn’t work.

When I add my remote camera directly as a MotionEye integration (so skipping the add-on as an inbetween) the streaming works. However, I’d like to limit my connections to the Raspberry Pi by making the addon connect to the Raspberry Pi (I plan on adding more camera) and then doing my viewing through the add-on.

So I’m thinking the api/camera_proxy_stream is just not able to fetch the remote camera stream for some reason. Hope someone can figure out why that’s the case. Thanks in advance!

Kind regards,


I have the same issue, have you find a solution for this?

MotionEye uses port 8081 for the stream. But the default port for the still images.
After adding 8081 port to my portainer configuration it worked.