motionEye snapshot url does not work

How to use the snapshot url provided by motionEye?
I get this:<random text>/picture/1/current/?_username=admin&_signature=<random text>

Using it works on the same browser where I’m logged in to home assistant. But if I try incognito or telegram notify I get 401 access error. I tried the example here following the user and password but does not work either. Same 401 error.

How to get the snapshot using this?

1 Like

I managed to add MotionEye stream as camera in home assistant. The live feed works but the snapshot does not.

  - platform: mjpeg
    still_image_url:<random text>/picture/1/current/?_username=admin&_signature=<random text>
    name: name
    authentication: basic
    username: user
    password: password
    verify_ssl: false
1 Like

And if I try to use the camera.snapshot service all I get is a file with this in it
“401: Unauthorized”

Also doesnt work for me. Did you find a fix?

No idea. I dropped the snapshot/still_image_url from the camera. Though I would need it at some point.

I have same problem. Did you find how fix it?

I’m sure it is something simple but have no idea.
I have the feeds in HA from the cameras and not using motioneye.

Same for me

Me too, stream works great… stills nada …

EDIT! Got it… just comment out the “Still” URL from your config file and HA figures out the the Picture Element needs a still image and pulls it in from MotionEye without the definition.


I think I tried that but could work different now :thinking:

I’ll check if it works for me as well!

I can confirm that the workaround to remove the still image parameter works. :+1:

This one was driving me nuts…Respect bro!

after adding above config to config.yaml file, i can’t see live stream. what card you guys using to view live stream ?

Maybe it helps…
I’m getting snapshots into Node-Red - then some processing with TensorFlow node to detect Persons on my cams.
Also having 401 error, but if I’m making HTTP request with Cookes - it is all ok!
So some authorization problem is here, but if you will use cookies it will work!