Motioneye will not save video feed

Tags: #<Tag:0x00007f739a944de0> #<Tag:0x00007f739a944c50>

Hi guys I need some help. I’m new to Home assistant and Motioneye and I have a problem making Motioneye save video feeds (default directory “/share/motioneye/Camera2”). Everything else seems to work just fine, and the video feed looks great.

I have connected a Reolink 420 camera, getting the video feed via “rtsp://192.168.20.xxx:554/h264Preview_01_main”. Hass.io runs on a Raspberry Pi 4.

Any suggestions ?

My setup is as follows :

Problem solved. If “Movie Passthrough” is not enabled, no video is saved.

Not really, I mean it solves the video creation, but we loose the timestamp… it should be work as expected.

I also cannot get the video to record. I’ve tried enabling and disabling the motion passthrough. It is too bad, the rest is working pretty well.

Photos were being recorded/

Strange, the Disk Usage bar graph under File Storage is increasing. Which makes me wonder if videos are being recorded but not showing up when I click on the Open Movies Browser (play button on the top right toolbar).

Is there another way to get to the share files. /share/motioneye/Camera1?

I remembered I can SSH into Home Assistant (nice add-on). I found the motioneye data directory and alas, no videos saved. Pictures yes, videos no.

It worked for me by changing the movie_codec option in camera-1.conf as the movie format option doesn’t show up for me in the UI. I had changed the default value for movie_codec from mp4:h264_v4l2m2m to mpeg4. In your case try changing the movie format and apply it to see if it solved your problem by going to the folder where your pictures get saved. The below link lists all the available codec options which you could experiment with

https://motion-project.github.io/motion_config.html#movie_codec

Capture

1 Like

Thanks @navrajan88. If you hover over the little question mark next to the video format it does mention that not all formats work on all systems.

mpeg4 worked for me :smiley:

Worked for me too! Thanks for the tip @navrajan88 :smile: