Motorola Camera's

Hi,

Wondering if anyone else has been using Motorola camera’s in Home Assistant?

In the last week Motorola has upgraded the firmware of my MBP853 and Focus85 to 0.10.32, which has left me with the inability to pick up MJPEG and FFMPEG streams via iSpy or Home Assistant.

According to Binatone this was done to improve the functionality of the camera’s, although, I don’t really think they had any idea what I was on about. Their reply was very generic both times and there was a lot of emphasis on the Hubble app, which I have rarely used, so, presumably, this is another company becoming cloud based and removing local functionality.

Home Assistant can still retrieve the temperature using the REST API, but, I can no longer retrieve the camera streams - anybody else in a similar situation and/or found a solution to get them working again with Home Assistant?

Many thanks.

Same problem here. Looks like 03.10.32 firmware bricked the streaming functionality. Haven’t been able to find a fix.

+1 . after 2 year of flawless use, it breaks with a firmware update
i spent hours trying to find an alternate URL/method and no luck.
also searched for a way to downgrade and nothing.
very disappointing change from Motorola. it should be a setting not removal.

Hope someone has better luck and posts solution here

update. no solution yet.

I found old firmware versions for my camera (and lots of Motorola cameras) here
http://18.234.4.251/category/nuvoton/mbp854s-1854/

And there is firmware upgrade GUI page hidden in camera interface-
http://IP-Address:8080/fwupgrade.html

it uploads the old firmware, but never actually processes it.

I never found a solution, I tried downgrading the firmware, like yourself, but, never had any luck. I noticed they did open another port on the MBP853 after closing the RTSP one, but, I can’t remember the numbers - sorry.

In the end, I gave up and e-mailed Motorola or Binatone as they like to call themselves. Here are their responses and in the end I gave up e-mailing them also as I realised it was pointless.

Thank you for contacting the Hubble Customer Support Desk.

I am afraid it is not possible to downgrade the firmware version of the camera.

Also please note that the Hubble cameras can be used only with the Hubble app.

If you have any issue using the cameras with the Hubble app, please describe the issue more detailed and I will be happy to help.

Please note that you have contacted Hubbleconnected customer support. Hubble cameras can only be used with the Hubble for Motorola Monitors app and we do not provide support for any third party apps. We do not guarantee Hubble cameras functionality when using them on third party apps.

Note that we upgrade the firmware of the cameras on a regular basis to improve cameras’ functionality.

Obviously, the last sentence is quite frustrating. It’s quite sad that this has been the road Motorola have chosen to go down.

I spent a lot of time, looking for replacements; camera’s that would hook up to a baby monitor and also integrate into Home Assistant and I am still yet to find anything that worked as well. Still very disappointed with it all.

@morles82

Checking into this also. Just bought a second cam, but couldn’t understand this one wasn’t working via HTTP or RTSP. Found out it had ID 1854 with latest firmware version. Then I read your posts here and see they somehow blocked port 6667 which is working fine on my old cam (ID 0085 and firmware version x.x.20).

Tried also to downgrade via the way you mentioned, it uploads fine, then it starts processing it, but nothing happens there. For now I think only way to make this work again is to downgrade.But yeah…how???

Do you have any other progress? Thx in advance!

Anyone? The baby is almost coming :wink:

Is anyone able to control the other functions of the monitor like turning on the Halo or playing the music from HA?

Hi, I managed to get some commands through by doing the following:

http://<IPADDRESS>?action=command&command=get_brightness
http://<IPADDRESS>/?action=command&command=get_contrast
http://<IPADDRESS>/?action=command&command=get_temperature
http://<IPADDRESS>/?action=command&command=melodystop
http://<IPADDRESS>/?action=command&command=melody1

Can’t get the video feed though. Hope someone figures out a way.

Hi all. I am having the same issue as you guys. The reason why Motorola/Hubble/Binatone did this is because of this blog article probably:

Like some of you, I also was on the downgrade path. I must say that I managed to downgrade, but it only worked for a couple of minutes, after which it auto updated itself again.

So I’ve had some kind of idea in my mind in which I downgrade the camera and then, based on the article above, hack myself into the camera and disable the auto update or somehow block it from accessing the internet. I am just not sure how…

Edit:
I have a Motorola MBP 855. The link to the “working” firmware package (if I recall correctly):
https://ota.hubble.in/ota1/2855_patch/2855-03.10.11.fw.pkg

“Broken” packages:
https://ota.hubble.in/ota1/2855_patch/2855-03.10.17.fw.pkg
https://ota.hubble.in/ota1/2855_patch/2855-03.10.18.fw.pkg

If you look in the Hubble app, there is a camera ID (in my case 2855) and a firmware version (in my case 03.10.18). Depending on your camera, I think you can change the numbers in the URL and change the version to just a couple of versions back.

Then try to upload it at:
http://IP-Address:8080/fwupgrade.html

But again, It will only last a couple of minutes unless you can cut it off the internet.

Question: Does anyone has a MBP-855? Just wanted to confirm the camera ID is actually 2855 (not sure if I broke it with downgrading).

Is your camera working normally after downgrading and it subsequently auto-upgrading to the latest firmware?

I’ve been looking here: http://18.234.4.251/ and the MBP-855 is referenced as 1855 and 2855 so I’m not too sure but if the app (and http://<IP_ADDRESS>?action=command&command=get_model ) tell you the model is 2855 then it’s probably right.

Do you have the links for the 1854 and firmware v03.10.16 maybe? It cannot find it when I change the numbers and version in URL

And how were you able to downgrade it? As I mentioned above in previous posts, I can upload the firmware, but the processing doesn’t do anything

After downgrading, it upgraded again.

I know I can get the model like that, I am just not sure if I see the model based on the firmware that I installed or that it is the actual model :wink:

So, When you do the “get_model” like above, you get in return that it’s the “1854” and not the “0854”? Just checking.

According to the page on http://releases.hubble.in, the latest version for 1854 is 03.10.32.
This is confirmed at the following page:
https://ota.hubble.in/ota1/1854_patch/version.txt

However, I am also unable to find the firmware at the following URL:
https://ota.hubble.in/ota1/1854_patch/1854-03.10.32.fw.pkg

Which kinda means that it’s different on your device :frowning:

So, I downloaded the latest present release again on the releases.hubble.in website and decompiled the ota_upgrade, which the other guy in the blog article also did.
I find code like this:
sprintf((char *)&str4, "%s/%s", "https://ota.hubble.in/ota1/1854_patch", (char *)g77);

Which clearly shows again that the first part of the URL is correct.

So I don’t get why nothing can be downloaded.

It works when I change the filename to 1854-03.10.16.tar.gz…I can upload it, but then the processing of the uploaded firmware stays on 0% forever. When I rename the file to 1854-03.10.16.fw.pkg, I can upload it, but then it says Upgrade Failed, wrong firmware.

So I’m still no step further

The tar.gz probably won’t work because it ain’t signed and they are not keeping the latest releases anymore on their website. So you should find the fw.pkg on their website. I discovered it by sniffing the traffic from their app I believe.

I’ll try to downgrade once more at home and create a video about it.

Are you able to find my fw.pkg file maybe by sniffing? I need the 03.10.16 firmware for the 1854. Thx!

Just as an aside, I contacted Hubble on Facebook and got the following response. The wording is slightly different from what @benm received and now explicitly mentions RTSP streaming not being something they support. Frustrating.

Please know that Hubble cameras can only be used with the Hubble for Motorola Monitors app and we do not provide support for any third party apps or streaming via RTSP.

No I can’t because I don’t have that camera :frowning:
I can only sniff my own camera.

Anyway, it’s clear that Hubble won’t bring back what they removed. So either we have to bring it back, find a work around or accept the fact that it’s no longer possible what we want.

Downgrading the MBP855Connect in steps:

Getting the current version:

Uploading the firmware file to the upgrade page (took about 15 minutes):

Upgrade started:

Upgrade completed (took about 5 minutes):

Checking the version again:

Seeing the video:

After about 5 minutes it upgraded itself to the latest version.