Mount existing hassos-data partition after reinstall

My HA was stuck in a boot loop. First thing I tried was to re-image the SD card. No worries I thought because all my data is safe on the hassos-data partition on my SSD.

I suppose my data is still there. But HA does not mount it. And all instructions I find are going to overwrite the data on the partition.

Wouldn’t/shouldn’t HA just mount an existing data partition? How do I get my setup back?

Thanks

PS: This is kind of a rhetorical question. I CAN recover my data. And I’m currently doing it.
But the user experience is far from logical or useful.

The most straight forward thing to do was to rename the hassos-data partition file system label on the SD card partition to make it non-ambiguous which one is to mount. That seemed to have worked.

But my boot loop is back. :joy:

The cause of the boot-loop was by the way that the Transmission downloader filled up all my data partition. No space left on device.

So for the record. This is how I solved it.

e2label /dev/mmcblk0p8 hassos-data-sd ## Any name that isn't hassos-data or hassos-data-old or hassos-data-new

That way it will pick up the hassos-data partition from the SSD next boot.