Mount NAS in Home Assistant Core - Docker?

Hi All,

Was hoping for some support on this. I’m trying to mount a NAS share on my Home Assistant Core and having some difficulty. My main objective is to be able to save snapshots/recordings from my security cameras to my NAS through Home Assistant. Is this at all possible? I was trying to follow the steps in this thread: [Solved] Hassio and volume mount issues and even had febalci assist me through DMs, but it still wasn’t really working correctly. Any assistance is appreciated. Thanks!

Intel NUC w/ i3 processor (DC3217BY)
Host OS: Windows 10 Home, however, running Home Assistant Core on Ubuntu 18.04.2 LTS via VirtualBox

mounting a share can’t be done at this point of time

what a Lot user do is use google drive

there a nice plug

that the i use

In ubuntu just mount the drive somewhere in your config directory. Put it in /etc/fstab.

There is no point in trying some hassio solution when you are not using hassio.

So I did modify my fstab file, mounting the NAS volume (for example, it’s a folder called /multimedia/cameras) and it’s linked to directory /mnt/cctv on the VM. How do I get it in the config directory at that point?

I would make a directory in your config folder on ubuntu operating system. If your mapped config folder is /home/integray182/homeassistant then

mkdir /home/integray182/homeassistant/www/cctv

Then I would change the mountpoint of the NAS volume to /home/integray182/homeassistant/www/cctv instead of /mnt/cctv

Well I feel like a dumbass. I could’ve sworn I tried that earlier and it didn’t work, which lead me down the rabbit hole. I followed your direction and voila, the directory showed up in Home Assistant with files that were already in the directory. Thanks for that, however now the next issue.

I tried going to the services tab and testing out saving a snapshot from one of my cameras, but the snapshot never saved and the logs show the below:

Source: components/camera/
Integration: Camera (documentation, issues)
First occurred: 1:26:17 PM (1 occurrences)
Last logged: 1:26:17 PM

Can't write /www/cctv/snapshot_<Entity Laundry PoE: streaming>, no access to path!

I assume this has to do with the permissions on the folder? However the permissions look the same with all other directories in the www folder:

total 4060
-rwxr--r-- 1 root root      53 Apr 16  2019 google9207316b768604e2.html
drwxr-xr-x 2 root root       0 Jun  8  2019 cctv
drwxr-xr-x 3 root root    4096 Feb 21 02:33 github
drwxr-xr-x 5 root root    4096 Mar  4 17:37 community

Actually, you can disregard my last message. I had to add “/config/www/” to the path in order for it to save in that directory. Looks like I’m all set! Thanks @nickrout for the help and @myle for the suggestion.

1 Like