Mount synology folder to hassos


After reading and experimenting a lot over the past couple of days, I can’t seem to find a solution.

In short: I want to mount a shared folder from my synology to my hassos/hassio running on a rPi 4.


  • Raspberry Pi 4b with:
  • HassOs 3.13
  • Home Assistant Core 0.110.1
  • Supervisor 224


  • SSH & Web Terminal 7.4.0 (Home Assistant Community Add-on by Frenck
  • Samba share 9.2.0 (Home Assistant Add-on)
  • Nginx Proxy Manager 0.5.0 (Home Assistant Community Add-on by Frenck)

Synology NAS:

  • DS213+
  • DSM 6.2.2-24922 Update 4


  • NFS is enabled on Synology
  • Shared folder has permissions for NFS
  • Created a folder on the rPi4 in /share (called synology/downloads)
  • I can only reach my Home Assistant instance (local/internet) thru my domain which is set to ssl and setup using Nginc Proxy Manager
  • I can access my synology thru local IP and thru the quickconnect ID

What I already tried:

  • Used command sudo mount -t nfs /share/synology/downloads
  • Also tried without the -t nfs option
  • When using this command thru ssh it gives me a ‘Connection Refused’
  • When using this command on a rPi3b+ which is running Raspbian, it’s working perfectly fine. So it is possible to connect thru nfs to my synology and mount a shared folder

I am guessing this has something to do that Home Assistant is running in a docker environment on HassOs. But I can’t figure out how to make it work, or if it is even possible to make it work thru nfs or on hassos.

I’d like to mount the folder so I can use the unofficial Sonarr package to scan my downloads folder on my synology. I used to do this on a rPi where I was running Ubuntu (also tried with raspbian).
This was working fine obviously. But on HassOs it is not working.

Can someone help me out?
All other topics about this subject seem to lead to a dead end.

Thank you in advance

home assistant can’t see wont access a network drive its not built for that

you can add the FTP plugin and use FTP put files on to the HA server

and use HA to create a backup and then us the google plugin to back them up to google drive

Thank you for the reply, but that is something else which I am not trying.
The addon Sonarr requires a folder which it will scan to see which files are already downloaded.
It has acces to different folders including the /share folder
If I could mount a synology folder to the share folder Sonarr can see the files.

It won’t actually download or place files on the HA server.

I hope it is still possible

@Borrel88 I don’t suppose you ever found a solution for this? I have a very similar setup and haven’t been able to get anything mounted.

Hi there,

No, I wasn’t able to do what I wanted to do. It seems you cannot mount a folder on HassOs.
So I decided to transfer everything to a setup where I use Ubuntu and have HomeAssistant in a docker environment. It’s a little hard to find out first how everything is working, but when you have set it up, it couldnt be better (opinion). I really like the flexibility I have and to be able to use my rPI with Docker for other things then HA.

MostlyChris posted a Youtube video showing how to mount a Synology NAS folder in the HA media folder. He used a HA shell command to issue the mount command.
Play media files from your NAS using Home Assistant