Moved to PI 3B+ Raspbiann + Hass

After a few months of not using my system due to being seemingly locked out of my hassio install on Raspberry (PI cannot connect to Wifi, errors with docker WLan up and down) and I couldn’t modify my config to use wired as the config file wasn’t available in the hass. I gave up…

So I figured i’d move to something more managable, easier to back up… So today I tried Raspberry Pi / Raspbian + installed using favious websites/scripts/etc. Frankly. I struggled.

Here are some that I used

So, here I am. I think i’ve got it installed, but when I do a netstat -an, I don’t see the normal hassio port open. I have no idea where my images are or what to configure…

pi@PI-Hassio:~ $ docker ps
018b61ec99cc homeassistant/armv7-hassio-dns:1 “coredns -conf /conf…” 40 minutes ago Up 15 minutes hassio_dns
0b472e6d3797 homeassistant/armv7-hassio-supervisor “/bin/ pytho…” 58 minutes ago Up 17 minutes hassio_supervisor

Ultimately I need to get Hassio running, then connect my z-wave USB stick so I can go through the processe of adding the 20 sensors again…

Whew… Looks like I may have made some progress. It seemed I had to do a “hassio ha start” inside the docker instance that was running all along…

The guides i’ve looked at were in all sorts of places but don’t outline

  1. if hassio doesn’t start
  2. How to troubleshooting - common steps
  3. How to remove all / redo (should be same doc?)

No idea if all the plugs and everything will work. Kind of feel like I may have taken too much of a challenge and I should just go back to hassio and accept the fact that if the sysetm has problems, I won’t be able to get in at console

However, Now trying to set up SSH and it’s enabled in the add-on store, I’ve sent the host port to 222. it shows up fine, but the password doesn’t work and no idea how to see logs… Wish there was a good guide on this>



(12:08:00) -> ssh [email protected] 222
[email protected]’s password:
Permission denied, please try again.
[email protected]’s password:
Permission denied, please try again.
[email protected]’s password:
[email protected]: Permission denied (publickey,password).

Your log says it is listening on port 22.

Also why do you want it on another port?

Frankly why do you want the ssh addon at all? Raspbian has ssh by default.

ssh to the host isn’t the same as ssh to the hassio container… you can’t run hassio commands from the host (well you can but not easily) I have ssh setup with the community ssh addon and use that to control hassio and have normal ssh for the host stuff.

I was thinking it would be possible to configure stuff on the hass container by editing stuff in the config directory, I hadn’t though of the need to run the hassio commands. Good point.

Main reason is that I want to be able to see into the host itself AND the hassio container so that I can remotely manage the system as the raspberry will be in the closet.

Does anyone have a complete guide for the Rasberry Pi 3 to get Hassio running with docker. I’ve ffound a few links but none were comprehensive. I had to search around to learn how to start hassio via the supervisor container…

Concerned that I won’t be able to manage this as I don’t know exactly what’s going on

You just follow the instructions for installing hassio as a generic Linux install. It’s a documented install method.

Thanks David. I struggled following multiple directions. At the end of the script, it said “Run Hassio” but I had to search around for the docker start HA command.

Currently dealing with trying to figure out how to get my z-wave USB stick to pass through tot he docker supervisor.

To be clear, the reason i’m trying to do it this way is because I had a rough experience with hassio right on the Pi…
ALso, right now trying to figure out why the SSH-Ad on with just a password isn’t working. Based on teh screen shot below, I was hoping the host port would be 222, then 22 into the hass supervisor. But the username root and the password I specified isn’t working. However, I don’t know where to get the logs to see what the hassio supervisor

These are the instructions, the whole instructions and nothing but the instructions

1 Like

you can’t ssh into the host (raspbian) AND hassio container on the same port (22). You will need to map a different port for which could be 222 if you want - but you need to use the community ssh addon. The instructions do say to not use the core ssh for this kind of install.

Search for dale3h’s script/install for hassio back when there was no HassOS for a Pi3B+… it still works but you might need to edit the script as the repo it uses has moved… But if you’re up to doing this kind of install you should be able to work it out!

In addition @kanga_who has written a very useful pdf which adds a couple of helpful points :slight_smile:


I guess this is where I got confused.

I thought this would do it, a port 222 on the raspbian host is bound to 22 on the container


I guess this disclaimer is all encompassing as “may not function correctly”

So I guess i’ll have to use the core SSH add-on and figure out a way to forward that to the docker? I cannot see how any general user will get this working. I spent hours trying to figure this out…

Thanks David. I will look for the script (Actually, I think it’s what I ran already) however I’m not 100% sure I understand all of the commands but most I can understand what they are doing. This is my first docker install (I normally use Vmware) — what’s confusing is that I cannot enter the hassio sli instance directly from the SSH on raspbian, which is why i’m trying to enable SSH on it.

All of this is because my last hassio directly onto my PI locked me out and i lost hours of setup.

I was referring to this:

Just we aware as I said, the images moved location (as I found when I setup my again on a new SSD and was following my old instructions which referred to a different repo location) Anyway, Nick posted the link to the official docs anyway.

Also, don’t forget, you can change the ssh port on the host system easily as well so that it doesn’t use port 22! Then the core ssh addon most probably works.

Anyway, I have used the generic hassio installation in Linux at least 3 times now and it’s great. (Including once with Raspbian Lite)

Thanks David. I’ll give this a try. Ultimately, I’m looking for a system that I can easily clone/upgrade/fallback and it would seem the docker deployment is the best for that…

I’ll give this a try to see if I can charge the Raspbian SSH port and test the core-ssh add on. What’s weird is that the port 222 is working but the password is not. Even using a very simple password that I couldn’t possible screw up returns a failure.

Any other module issues that you’ve seen? Next step is to get the z-wave USB stick going

There’s two ssh addons. Install the “ssh & web terminal” addoin instead. It’s in the community repo and better for the generic linux installation you have moved to. (It also has more options and versatility all together)

I don’t know what you mean by locked out, but switching to another operating system, you’re only adding a bit more OS to the pi, and still running the same Hassio/Docker environment. Nothing is going to change for you except that now you need to deal with the caveats of choosing a different OS (This dual ssh situation being one of them).

“wlan up and down messages” are normal to see. Wifi isn’t a good choice for a server, but you probably could have dealt with your original issue once you had a little more guidance on how to get into the OS and use nmcli to either fix your connection issue or clear it out and create a new connection profile. This could have been accessed by connecting a keyboard and monitor to the pi, logging in as root, and then entering login at the next screen to get to the host console.

Thanks cogneato for the response…

I’ll take a look at this option tonight. My other option i guess is to run the ssh server of the Raspbian OS on another port.

I had a keyboard and montior connected to the Pi and the messages were Wlan disabled, enabled, forward, disabled. No matter what I did, it just wouldn’t stay stable. I tried even moving it withing 15 feet of the (very strong) AP… I tried 2 power supplies, measuring the voltage and output and they were as documented.

When connected locally, I couldn’t get into the hassio configuration at all. I’m sure I posted to this forum but cannot seem to find the post. I also asked in a discord chat. Went so far as to take the memory card out and into a reader on another pc. I gave up and now trying again with Raspbian.