MPD not working on Android tablet


I am trying to mount an Android wall tablet near the front door which can have the alarm panel displayed as well also have few other dashboards from Home Assistant. Currently I have a MPD player working on another Ubuntu machine but it is little far from the front door so I had the bright idea of installing MPD on the Android tablet ( From Android store ).

After MPD installation on the Android tablet, I tried executing following under Developer Tools => Services:

service: tts.google_translate_say
  entity_id: media_player.tablet_mpd
  message: Hello!

There is no sound on the tablet for above commands and I also see following errors on the Android Tablet:

Seems like the MPD on the tablet is receiving some input from HA but not sure why it is not working. If anyone has any insights on this then please point me in the right direction.


Not quite sure, but I believe it has something to do with SSL (it generates a “https” link). In my case the generated link to mp3 is plain http and it works.

1 Like

The app does not currently support https.
It’s been added, though

1 Like

Thanks @AdmiralStipe & @koying !!

I see that the above linked MPD Android issue was resolved, but I still get errors in Android MPD when trying to send cloud TTS. “Failed to decode”. Home Assistant is sending an http:// .mp3 file, so it’s not an https:// issue. Just the Failed to decode message with “Error” at the end of the exception message.

Follow-up on my above post. The issue seems specific to my Google Pixel 1. I’ve tried it on a Galaxy S6 (that’s still on Android 6), a OnePlus 6T, and a Haoqin H8 tablet, and had no issues with MPD.