MQTT and Ring-MQTT

Question 1 - mqtt

I have HA Core installed in docker along with various add-ons (MQTT, Node-red, Hass config). I just got my Z wave stick and I’m trying to get MQTT to recognizes devices, but it’s not detecting anything.

Below is my docker compose which seems to be working correctly as I was able to configure the MQTT integration in Home Assistant, but no devices are recognized after multiple restarts

    image: eclipse-mosquitto
    container_name: mosquitto
    restart: unless-stopped
      - 1883:1883
      - /share/Appdata/mosquitto/config:/mosquitto/config
      - /share/Appdata/mosquitto/data:/mosquitto/data
      - /share/Appdata/mosquitto/log:/mosquitto/log
      - TZ=America/Los_Angeles
      - /dev/ttyACM0:/dev/ttyACM0 #Zwave usb location

Question 2 - ring-mqtt

I’ve also setup ring-mqtt in docker and modified the URL with the MQTT URL, but the instructions on the ring mqtt wiki aren’t entirely clear. The instructions state the the MQTT broker is in standard MQTT URL format which should be added to my config file prior to container startup:


For example should that be translated to:

mqtt(s)://Bruce:[email protected]:1883
##or this?

I’ve tried both variations and I keep getting the following error:

Running ring-mqtt...
2023-04-13T17:28:49.462Z ring-mqtt Detected runmode: docker
2023-04-13T17:28:49.464Z ring-mqtt Configuration file: /data/config.json
2023-04-13T17:28:51.005Z ring-mqtt Reading latest data from state file: /data/ring-state.json
2023-04-13T17:28:51.018Z ring-mqtt WARNING - Unhandled Promise Rejection
2023-04-13T17:28:51.018Z ring-mqtt TypeError [ERR_INVALID_URL]: Invalid URL
2023-04-13T17:28:51.062Z ring-mqtt Attempting connection to Ring API using saved refresh token...
2023-04-13T17:28:51.640Z ring-mqtt Successfully established connection to Ring API using saved token
2023-04-13T17:28:51.641Z ring-mqtt Received updated refresh token
2023-04-13T17:28:51.642Z ring-mqtt Saving updated refresh token to state file
2023-04-13T17:28:52.653Z ring-mqtt Successfully saved updated state file: /data/ring-state.json
2023-04-13T17:28:53.641Z ring-mqtt Attempting connection to MQTT broker...
2023-04-13T17:28:53.644Z ring-mqtt Error: Missing protocol
    at Object.connect (/app/ring-mqtt/node_modules/mqtt/lib/connect/index.js:72:13)
    at Mqtt.init (file:///app/ring-mqtt/lib/mqtt.js:85:41)
    at EventEmitter.<anonymous> (file:///app/ring-mqtt/lib/mqtt.js:27:22)
2023-04-13T17:28:53.645Z ring-mqtt Could not authenticate to MQTT broker. Please check the broker and configuration settings.
[17:28:53] WARNING: A critical error was detected, shutting down container...

Problem solved. I use the wrong format for the mqtt URL as it should be something like

mqtt://Bruce:[email protected]:1883