MQTT auto-discovery issue


I’m pretty new in Home Assistant, I’m doing a project for my university that consist in integrating automatically sensors in Home Assistant. For that I connect to my university’s broker where I can only subscribe to specific topics.

I have to automatically add sensors to Home Assistant. These sensors send values to the topic “//” in JSON format.
Example sensors we have and their messages:

(To assure uniqueness we have subID, unitID, and the topic)

The problem is that when I enable auto-discover Home Assistant try to subscribe to “tasmota/discovery/#” and it’s not allowed so the broker disconnects me. Mqtt mosquitto connects again, do the same and disconnects over and over.

How do I disable that tasmota discovery but keeping homeassistant discovery?
Thanks in advance.