MQTT broker problem

Greetings to the forum,
at the moment I have a problem that I can’t explain myself.
I have latest version 192 Hassio.
I installed the MQTT Broker addon.
I have several shellys that work perfectly.
A few days ago I set up a new shelly and added it to HA and it all worked on the desk.
After a few days (today) I installed this shelly, which remained unpowered until today, in the box where I had planned to install it.
The shelly worked after reconfiguring the access to the wifi (probably being out of power it had lost the settings)
However, as soon as it was configured, it worked from the first moment with its application on the iphone.
I set mqtt on the shelly but HA can’t see it.
On the MQTT log page I see all the shellys but not the one just installed.
I tried with mqtt explorer and saw them then I deleted it from mqtt explorer and now I don’t even see them there.
So I tried to remove and reinstall MQTT Broker from HA but the shelly one I don’t really see.
What is it that can give me this problem?

Thanks, Alberto


… in the shelly I continued to add port 8123 instead of 1883 … I have no words :flushed: