MQTT Challenge - Help needed

I have been running mqtt with the pentair screen logic addon without issue for many months. My mqtt switches stopped working. When i toggle them off or on , they go back to the original position within seconds.

The message is getting published correctly to the command topic., when i publish the same message via mqtt.fx it has no effect either. I have not changed anything on my network. I am running HASSIO with a virtual box vm on my mac. I even downgraded my virtual box software thinking that may have been the cause. I have this issue for about a month, and I really need help.



Ok a couple of questions here,

  1. (first step in any computer system :smiley: ) Have you restarted your MQTT broker?
  2. If you use a tool like MQTT-Explorer to monitor traffic, can you see your broker send out the commands it receives?
  3. Are you using the retain flag on your devices?

Thanks for the reply.

Yes I have restarted the broker. I even tried a fresh install of Hassio with the same results

I can see the message sent out.

I have tried with both retain flag and not

Where would you go from here. Thanks for the help

I saw this before but with tasmota switches. And the problem was that the new version of tasmota changed the topic “power” to “power1”. So the state topic on HA was pointing to a topic that no longer existed. Check the state topic and change it if necessary.

1 Like

Ok, one bit to remember with the retain flag is that turning it off on the device doesn’t clear the last retained message on the broker. If you use MQTT-Explorer, then there is a function to clear retained messages.

Are you seeing messages being received by the broker in the broker logs? ie:
1599878787: New client connected from as DVES_740D46 (p2, c1, k30, u'device').

I’d also venture a guess that a command is retained where you may not think it is.

I’ve found these instructions very helpful to remove those retained messages

I’ve been into MQTT for about a year now, I never could see any value at all over that setting, it’s just a hinderance for situations like this.


How would I check that?

Not sure as I dont know the addon you are using, but from mqtt tool you are using you may see what the addon/broker are using to report state.

Thank you to everyone for your assistance.

There are no messages being retained and using mqtt explorer , i am able to see what appears to be the correct messages being published. So it appears to be between the queue and the screenlogic adapater?

Which in my mind would point to a network issue or the topics changed, but there has been no change either to the screenlogic firmware or my network that i know of…

Any help would be greatly appreciated, I am not sure where to go from here.


1 Like

I’m not familiar with the devices you’re using but in looking up the settings it uses, I did find this article. See if this is helpful or not: