Mqtt clients unable to connect

I have setup mqtt broker using the homeassistant add on and I am able to send and recieve messages right now using the publish and listen feature in the mqtt addon. But the problem is I am unable to connect tot he broker from any other device, tried mqtt-explorer and ratgdo device. Both fails. I am running Home Assistant inside Raspberry Pi 4. Are there any other settings that needs to be enabled?

Generic MQTT help can be found here (with lots of links to the docs):

Oh, and HASS doesn’t like IPv6 just in case that could be an issue for your network.

If this helps, :heart: this post!

I figured that I was reaching the homeassistant url but I was running that behind a proxy, So I had to use the ip address of the raspberry pi to get it working. Sorry for wasting your time.