MQTT configuration give me some troubles ;o(

Tags: #<Tag:0x00007f32892e84f8> #<Tag:0x00007f32892e83b8> #<Tag:0x00007f32892e8250> #<Tag:0x00007f32892eff28> #<Tag:0x00007f32892efe10>

Hello, :smiley:

First of all, it’s my first post…so : THANKS SO MUCH to EVERY DEVELOPPERS of HA !! Very nice job ! Next, sorry for my english ; :smiley:

I’m running Hassio on Tinker Board-S, in Docker (under Debian GNU/Linux 10), HA version . :+1:

I have some integrations already working like Z-Wave, Neato, Netatmo…Etc. But, I’d like to pass through the Do It Yourself usinf ESP8266, ESP32CAM….Etc. :muscle:

I bought ESP32 CAM and parameted them really easily through ESPHome Integration…

For the other ESP through MQTT…it’s more difficult :

I tried that video but I had no issues : https://www.youtube.com/watch?v=H5miv_fdBZY. I asked myself if it’s not because I’m running in Dockers.

In Portainer The IPV4 Subnet is 172.20.32.0/23

I always have the HAssio notification "Login attempt or request with invalid authentification from 172.30.32.2.

I have indeed that notification lot of time while my Tinker Board IP is : 10.0.4.120.

I tried that solution…but it doesn’t works also :sweat: :

Login « Ha » and password « Hamp » are not mines but it’s just an example

I installed Mosquitto Broker :

  •     Login : Ha 
    
  •     Password : Hamp
    

I created the files :
image

I gave permissions to Users already created in Hassio (Integrations/Users):
image

I bought Anavi thermometer : https://github.com/AnaviTechnology/anavi-thermometer-sw and flashed the binary file [anavi-thermometer-sw-102-20200510.bin] from “relases” with ESP-Home Flasher.

In ESPHome, the ESP8266 looked connected to HA:
image

I didn’t included parameters in the .bin but directly through Wifi configuration :

The ANAVI Thermometer IP Adress is 10.0.4.51 and it looks to works well in the Home Flasher Log :

In HA, I installed ESPHome :
esphome:
name: exmaple
platform: ESP8266
board: nodemcuv2

The problem is : I can’t use MQTT and include my Anvi Thermometer in HAssio…

The parameters in Hassio’s MQTT integration are :

  •     IP : 10.0.4.120
    
  •     IPort : 1883
    
  •     ILogin : Ha
    
  •     IPWD : Hamp
    

BUT … I changed my password (shorter*) ant topic’s name ! I disabled my MAC address filtering on my router.

It works !!

**Precision: my PWD was really more long than “Hamp” wich is only an exemple and contained capitals and lowercase. I’ll look another time if capitals could be the problem…"

image
ALLELUIA… :star_struck:

here … if it can be used for others … :grinning:

A first problem appeared : In HA, I have the following msg in Mosquitto Log :
image

Looks that Socket error on client went from “false” variable in the configuration :
image

I changed it by “True” and looks to works better :slight_smile:
image

The problem is that Ithe sensors disappears in “entities” :slight_smile:

ALLELUIA AGAIN… :star_struck:

I just improved it by installing the Mosquitto Broker directly on the Dietpi Exploitation System…
image

image

image

Then in configuration.yaml :slight_smile:
image

And…so happy :slight_smile::
image

THE PROBLEM is…I now have impossibility to use Zwave with the mosquitto broker away from mosquitto-core. The OZWave need MQTT Broker https://www.home-assistant.io/integrations/ozw/
Does anyone has the solution please ?

I 'd like to use the MQTT Addon but The WifiUnifyManager on my ESP8266 is limited in caracters meanwhile Hassio Integration for Mosquitto Broker give a really long password :slight_smile:
image
What could be the issue please ?

Hello !! The solution is to use ESPHome Addon. I spoke with Leon who completed my .yaml. Many thanks to him for his customer support.

he put the yaml on Github. You just have to download it then:


Then, install the ESPHome Addon

In ESPHome :
image

Clic “+” in the bottom right then Choose ESP8266
:slight_smile:

Edit the yaml by adding the Leon one’s !!

Vlidate it then Upload it on the board…and it will works welll !!

Think to delete the mqtt parameters in the configuration.yaml and think to create the accesscontrolist

Login « Ha » and password « Hamp » are not mines but it’s just an example

I installed Mosquitto Broker :

Login : Ha 
Password : Hamp

I created the files :
image

I gave permissions to Users already created in Hassio (Integrations/Users):
image

After that, your Anavi’s thermometer will reach your Mqtt broker without difficulties even with the basic parameters of the broker while you entered the good wifi parameters ans Mqtt parameteres in the ESPHome yaml :
image