MQTT controlled Cat Feeder

Hey, i noticed i haven’t posted this here yet.
here is an album of the device:

and here is the code for the nodemcu and schematics:

Please do share if you intend to replicate or improve it.




oh man you need to sell these at vet hospitals for sure, get a patent quick lol. SHARK TANK!

NICE WORK! Do you have a link to the cereal dispenser?

1 Like

i second this! lol

Yeah everything is already on the github page guys :slight_smile:

This is the cereal dispenser:

It was cheaper when I brought it so maybe check ebay? :slight_smile:

Hi everybody,

@lance36 thank you for your work I’m trying to build it !!

I have a kitten who doesn’t eat a lot, so I wish to weight the food remaining in the plate and not activate the script if not empty. I think about this:

What do you think about? The weight is aroud 40g?

Do you think to another solution ?

Thank you !

Hi everybody !!

I’ve got a problem during tests… my stepper motor produces vibration but don’t turn.
I checked every wires, and it’s identical to you.

It’s like if there were not enough power to turn him, but I though it was sufficient…

Do you have a solution ?

Thank you !!

others suggested the use of a force sensor to check how much food is in the plate and\or for motor malfunction so i guess you should give it a try and report back? :slight_smile:

The only other solution i could think of is another distance sensor, but cats dosen’t seem to like ultrasounds very much, i actually swapped mine with an infrared sensor, which was quite pricey compared ultrasonic one.

why did you withrdraw your post about the pressure plate? :slight_smile:

try to replace line 39 with

Stepper myStepper(steps, D1, D3, D2, D4);

lemme know

if it dosent work play with those values a bit. the PSU should be enough.

Delete the post was an error… :blush:
Normally it reappeared !!

For the motor I already had:
Stepper myStepper(steps, D1, D3, D2, D4); but I will try another combinaison that an idea !!

But unfortunately I can’t try today: because of inattention I burned my nodeMCU… :sweat:

I will receive my new one tomorrow !!
I can not wait to try!

I’ll send you a picture when it will be active!


Most likely you just burned the ams1177 which is a voltage regulator, check it with a multimeter and just replace it if you have a soldering iron :slight_smile:

Ok, my motor turns… but the croquettes remain stuck in the flexible propeller…

I think I need a motor with a torque higher…
So my solution is to reduce the motor speed to incease the torque, but the L298N is really really hot !! Does it normal?

I think it should be hot (the builder won’t install a dissipator in other case), but here I’m pretty worried about that, I’m affraid it’s exploding!

Do you have the case?

thank you!

EDIT 09/17:
When I load the motor with the max of food, I broke the nodemcu…
My suggestion is the motor ask too much current (but the power supply unit is 12V - 1.5A) and overload in current the nodemcu… I thought it was protected with anti-return diode…

Do you have this problem too ?
What is your stepper motor? Mine is 17HS4401.

thank you !


Did you every find the solution im having the same

@lance36 @Will711990 @myle I’m working on this project but have never worked with stepper motors either.

My NEMA 17, similar to others, will vibrate shudder (it moves slightly, but only a few degrees in either direction - never consistently in the same direction.

I’ve tried re-wiring all the leads to the L298N for all four combinations of steps (I did this to avoid having to re-flash the nodemcu each time) and get the same result each time.

Did anyone find any useful troubleshooting steps along the way in the process?



I never find a solution with the stepper motor…

But i’ve got a Catfeeder which works with a DC motor !! That easier to control, and the L298N heats less !

be careful. wiring is not equal. D2 and D3 swapped.
check wiring again:

IN1 = D1
IN2 = D3
IN3 = D2
IN4 = D4

Yes, thank you for this info. Yesterday I realized swapping the wires wouldn’t be enough and actually went back and flashed 24 times (for science!) with every possible permutation of the values. I ran into three odd behaviors:

  1. As expected, four of the stepper motor settings/permutations worked better than others. But curiously the motor still only moves about 30 degrees instead of the 90 degrees you’d expect (The code calls for 50 steps, and since it’s a 200 step /1.8deg per step motor 50 steps should be a 90 degree turn)

  2. Since I couldn’t get a 90degree turn out of the motor, I changed the code from 50 steps to 150 steps. With the motor driver on 12v power and the nodemcu connected to my PC by micro usb, the code will turn the motor about 90 degrees – but in three short bursts instead of smoothly as you’d expect.

  3. If I unplug the nodemcu from micro usb and instead run everything just off the 12v 2a power supply, the motor only manages one short burst (30 deg) before stopping and the nodemcu appears to reboot itself. It seems like there isn’t enough power from the 12v power supply to power both the motor driver and the controller for a short 90 degree rotation, which seems unlikely to me… obviously something else is going wrong but I can’t figure it out.

I have the same Problems and no Idea :frowning: for secound my food sensor don´t work.
i checked the wires 100 times.

Maybe some has an idea.


Can you connect the GND terminals of the power supplies of the nodemcu and the motor drive to each other and try?