MQTT Discovery of new Tasmota device

I’ve been using HA with the MQTT Broker add on for several years and recently added a device flashed to Tasmota32-bluetooth and configured with “so19 1”. Unlike before, this device is not being auto discovered. MQTT-Explorer does see messages from this device.

I have been updating HA periodically. Did something change in HA that I missed where I should have made changes in the configurations related to MQTT Discovery?

HA is version 2022.3.6
Eclipse Mosquitto Broker add-on is version 6.0.1

I recommend you consider switching to Tasmota’s native discovery method (SetOption19 0) because they deprecated the use of Home Assistant’s MQTT Discovery method several months ago. Eventually they will eliminate it from their release version.

1 Like

Thanks for the pointer.

I will probably do it this weekend since I don’t know what things this will break.

Do I need to uninstall the MQTT Broker add-on at the same time?

Don’t uninstall the MQTT integration because it is still used by the Tasmota integration (which you will need to install).

I tried it with one device and it worked though some entity names changed.


1 Like