MQTT does not recognise Tasmota sockets

I have activated Mosquitto Broker via the Homeassistant add-ons.
I created an extra user in HomeAssistant and entered it in the Mosquitto Broker Config.
I have entered the IP address of the HA Raspi and port 1883 in the Tasmota sockets and the created HA user.

The logs also show that a device is responding.
Later it says that it will be entered in a Mosquitto DB.

The sockets are neither under entities nor in Loveplace.

Do I need to configure anything else in HA? (configuration.yaml)

I have also in the configuration.yaml simply
IP address

… and deactivated the add-on.
But that didn’t work either.

I hope someone has an idea.

Ensure your Tasmotized devices are configured with this option:

SetOption19 0

NOTE: the “lite” version of Tasmota doesn’t currently support automatic discovery. Ensure you are using the full version.

Use an MQTT client (like MQTT Explorer) to view all the topics on your MQTT Broker. There should be topics beginning with the root name “tasmota”. These topics contain information, that is used by Home Assistant’s Tasmota integration, to automatically create devices and entities.

Thank you. Those were the decisive hints.

I was able to enter the SetOption19 0 (=> Tasmota discovery by default) via the console of the Tasmota WebUi.

I thought I had installed the latest version after the Tasmota Flash (version 9.2.0 (lite)).
After upgrading via the Tasmota WebUi, I have now installed 9.3.1. (tasmota).

All sockets were immediately displayed correctly in the HA under devices and entities. I also now have them in the overview via Devices => Add to Loveplace.

Unfortunately, this is not documented in a very user-friendly way. Maybe immediately obvious for an insider, but not for a beginner.

Can I support the community in creating better documentation?

1 Like

Feel free to update Home Assistant’s documentation but you will simply be duplicating what is more than adequately described in Tasmota’s own documentation. After all, if you went through the effort of flashing a device with Tasmota, you should become familiar with what you just installed on the device.

Everything I explained is mentioned here, in a very user-friendly way:

Tasmota - Home Assistant

Perhaps all that is needed is to add a line in Home Assistant’s Tasmota integration documentation that mentions the prerequisites are in the link I just posted.

Yesterday I lost/crash on of my sockets after updating it.
(When I plug it into a socket, the button lights up briefly and then nothing. I have already pressed the button for 30 and 40 seconds, waited 30 minutes, plugged it in seven times and after 10 seconds plugged it in again (and after 10 seconds plugged it out again)… but everything has not helped.)

Are you sure that the Lite version does not work?

From the documentation link I posted above:

Screenshot from 2021-04-20 11-53-16

Thank you so much! Upgrading helped in my case too!

Hello everyone, in my case I have all Tasmotas already enabled to be discovered, the oldest system is 6.2.1 and the new one is 12.4.0. I have both 6.2 and 12.4 unrecognized, that’s 8 devices and Tasmota only recognizes 3 H.A. installed version 2023.2.5

tasmota ADM
Tasmot Integration

What is the Tasmota version of the 3 devices that are recognized?

Hi Taras

Program Version 10.1.0(tasmota)

Program Version 9.3.1(lite)

Program Version 7.2.0(lite)

That’s all versions not recognized.


Are your devices configured to use Home Assistant’s MQTT Discovery or Tasmota’s Discovery method?

The latest version of Tasmota firmware now uses Tasmota’s Discovery method and not Home Assistant’s MQTT Discovery.

Sorry, I don’t know the difference between these 2 methods. Can you send me examples or the path to the information?


I found what´s goinon, even after i change de frendly name to Tasmota all swiches in mu mesh router are not reconizided, only , i had ro add then via configuratio yaml.