MQTT Event Stream Hang

I am using MQTT Event Stream to stream state to a dashboard I am working on, and every time I enable it, hass hangs on shutdown forcing me to SIG_KILL it :frowning:

I have tried this with both the built in MQTT server and Mosquitto with identical results. Suspecting that the subscribe part was blocking, I disabled it since I am not using it, but even just publishing the events causes the hang.

I have reviewed the code and can’t see anything obvious - when I was using the internal MQTT server I suspected that there might be a race condition on receiving EVENT_HOMASSISTANT_STOP and trying to publish it to a potentially shutdown MQTT server, but I filtered those events and got a bunch of other errors and inconsistent results so I don’t think I have got to the bottom if it.

Has anyone else seen this, or does anyone have any suggestions? I am willing to test and make a PR to tidy this up if anyone can give me a hint.

1 Like

Yes, I’m seeing the same result. It seems that there is an endless loop, the database keeps growing rapidly.

I’m also having this problem! Any fix?

Not that I am aware of - I stopped using it in the end.