MQTT failing after it had worked before on 0.6

So I had set up my rpi3 as an mqtt listener by running a script on it.

My rpi2 which has hassio installed would use commands to send mqtt messages to the rpi3 which controls a relay board via ble via python scripts. I know the python scripts still work because if I run them manually on the rpi2/hassio the relays are activated just fine.

The way the rpi3 would listen was via a script,
import paho.mqtt.client as mqtt
from failedPythonBLE import turn1ON,turn1OFF,turn2ON,turn2OFF,turn3ON,turn3OFF

MQTT_SERVER = "hassio.local"
MQTT_PATH = "test_channel"

def on_connect(client, userdata, flags, rc):
    print("Connected with result code "+str(rc))

# Subscribing in on_connect() means that if we lose the connection and
# reconnect then subscriptions will be renewed.

# The callback for when a PUBLISH message is received from the server.
def on_message(client, userdata, msg):
    print(msg.topic+" "+str(msg.payload))
    # more callbacks, etc

if str(msg.payload)=='01':
    print "letsGoBaby! Turn On Relay 1"
elif str(msg.payload)=='02':
    print "Turn Off Relay 1"
elif str(msg.payload)=="komp-on":
    print "Turn On Relay 2"
elif str(msg.payload)=="komp-off":
    print "Turn Off Relay 2"
elif str(msg.payload)=="sole-on":
    print "Turn On Relay 3"
elif str(msg.payload)=="sole-off":
    print "Turn Off Relay 3"
elif str(msg.payload)=='07':
    print "Turn On Relay 4"
elif str(msg.payload)=='08':
    print "Turn Off Relay 4"

client = mqtt.Client()
client.on_connect = on_connect
client.on_message = on_message

client.connect(MQTT_SERVER, 1883, 60)

# Blocking call that processes 
# handles reconnecting.
# Other loop*() functions are available that give a threaded interface and a
# manual interface.

Error Im getting in tmux running the mqttListen:

Traceback (most recent call last):
File “/home/pi/Documents/python/”, line 49, in
client.connect(MQTT_SERVER, 1883, 60)
File “/usr/local/lib/python2.7/dist-packages/paho/mqtt/”, line 839, in connect
return self.reconnect()
File “/usr/local/lib/python2.7/dist-packages/paho/mqtt/”, line 962, in reconnect
sock = socket.create_connection((self._host, self._port), source_address=(self._bind_address, 0))
File “/usr/lib/python2.7/”, line 553, in create_connection
for res in getaddrinfo(host, port, 0, SOCK_STREAM):
socket.gaierror: [Errno -2] Name or service not known

What should I look into? The paho package?

I had to post this because I back to my terminal, (logged into rpi3), killed the failed tmux session mqttListen, created a new one, ran the python script, it ran fine outputting this:

root@raspberrypi:/home/pi/Documents/python# python
Connected with result code 0

and now it all works.