MQTT integration does not find sensors/entities

I’m using mosquitto in Home Assistant 2021.1.1, both in docker.
I have configured the mqtt integration with 1270.0.0.1 and it did find (most) of my sensors. I wanted to modify that to the real IP-Adress of my Pi and did a re-configure, but the integration does not show any known entites.
I removed the integration and added it again. Same result, No entities. Did again a re-configure of cause all with “Enable discovery” set. Same result.
How could I find my entities again?

Disable listening on insecure (1883) ports

Remove the ports from the add-on page network card (set them as blank) to disable them.

(see https://github.com/home-assistant/addons/blob/931d126b97e538c81704447035ce20f7497d37aa/mosquitto/DOCS.md#disable-listening-on-insecure-1883-ports)

Did you (by any chance) do this, so the MQTT server is not exposing port 1833 to the host’s network?

Not sure, if I understand your suggestion.
I have a MQTT explorer running on my Laptop which can connected via shown IP using default port 1883 and does show my sensors.

(I do not have the Add-ons. I’m runnung HA and mosquitto in docker.)

Ich lasse Home Assistant Core, Mosquitto und zigbee2mqtt auch als Docker container laufen und hatte die Vermutung, dass der Mosquitto-Container keine Ports freigibt. Dann wäre er nur auf der internen IP (Docker) erreichbar und nicht über die IP des Hosts.

Aber das scheint ja nicht der Fall zu sein…


I also run Home Assistant Core, Mosquitto and zigbee2mqtt as Docker containers and had the assumption that the Mosquitto container does not release any ports. Then it would only be accessible on the internal IP (Docker) and not via the IP of the host.

But that doesn’t seem to be the case…

I tried a lot and got it to work…
but no idea what made it run.