MQTT integration issue


I installed mosquito on my machine, and was able to start the HA MQTT add on. But I don’t see MQTT in the integration. When I try to add it manually, it asks for the broker. I guess this is the local IP address of the machine that Mosquito is installed on, but it does not work.

What am I doing wrong?

Here is the add on log

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/
[22:11:27] INFO: SSL is not enabled
cont-init: info: /etc/cont-init.d/ exited 0
cont-init: info: running /etc/cont-init.d/
cont-init: info: /etc/cont-init.d/ exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun mosquitto (no readiness notification)
services-up: info: copying legacy longrun nginx (no readiness notification)
s6-rc: info: service legacy-services successfully started
[22:11:28] INFO: Starting NGINX for authentication handling...
[22:11:28] INFO: Starting mosquitto MQTT broker...
2022-09-21 22:11:29: Warning: Mosquitto should not be run as root/administrator.
[22:11:29] INFO: Successfully send discovery information to Home Assistant.
[22:11:30] INFO: Successfully send service information to the Supervisor.

What sort of installation is this please? The log suggests HASS OS with the Mosquitto Add-on (which is seperate from the MQTT Integration - a trap for many) ?

You have posted the Mosquitto add-on log (no, nothing is obvious when remote debugging!), and I can confirm that my own working installation gives pretty much identical log information. The root/admin warning is normal.

My suspicion is either you’ve not set up any users (user homeassistant is disabled, one for server and others for types of clients like tasmota can be useful), or perhaps the Integration has a config issue. IPv6 is unlikely to work - an ongoing limitation of HASS OS.

Rather than ask lots of questions, I’d suggest trying a step-by step guide written for another issue:

The Integration should work out the mosquitto IPv4 automagically, but a good test of Mosquitto (and your understanding of MQTT…) is to use an external tool like to connect to the broker. It’s more immediate and visual than the Tasmota console.

If this helps, :heart: this post!