MQTT Integration not working with External Mosquitto broker configured with SSL/TLS

Hello, We have Mosquitto Broker configured with SSL/TLS over port 8883.

It connects with Mosquitto clients, MQTT Explorer, and other MQTT clients using certificates. (no issues)

Even it is working with Zigbee2MQTT integration, Configuration can be seen in the image attached.

But Can’t connect using MQTT integration. Have tried many settings. (tls_insecure: false, tls_insecure: true, provided all certificates, tried with ca certificate only as well).

Note: Broker ipaddress and port are configured in MQTT integration UI.

Also, i can’t see any logs of MQTT, I have enabled them in the logger. (tried both debug and error)

Mosquitto Broker Configurations.
image

zigbee2mqtt configuration (working fine)

I have the following in my Mosquitto Broker configuration:

logins: []
require_certificate: false
certfile: fullchain.pem
keyfile: privkey.pem
customize:
  active: false
  folder: mosquitto
allow_anonymous: true

I have the same exact issue. Did you ever solve this? @danishshahid