Mqtt integration setup in configuration.yaml does not work

Hey there,
I tried to setup the mqtt integration in my configuration.yaml but it seems like, it is just ignored. Setting it up from the ui works perfectly fine but when configured in the configuration file, it does not show up although it discovers the broker. It also reads the config correctly because it tells that some options are deprecated which shouldn’t be a problem. Does someone know why that’s the case? I want to make my setup reproducible by configuring all in .yaml files. But it seems like configuring Integrations does not add them automatically and also in case of mqtt it ignores it completely.

I know there’s the topic [solved] .97+ issues - mqtt in configuration.yaml ignored, no dns but its pretty old and there I think there was no answer.

The following is from the 2022.3 release notes, which may explain what you’re seeing:

An MQTT configuration in configuration.yaml no longer results in an imported integration entry, MQTT must now be set up from the frontend.

Please note that:

  • Any previously imported configuration is still valid, this PR does not remove or modify imported configurations.
  • It’s still possible to configure MQTT entities and advanced broker configurations, such as SSL certificates, via YAML.
1 Like

Unfortunately that is not possible any more because many integrations are only configured exclusively thru the UI and the ones that aren’t may/will be transitioned to only UI config at some point. Much like you are seeing with MQTT.

1 Like

Thanks for the replies. This sucks hard. Why remove a additional useful features. It reminds me to the “beef” with the nix community and makes my developer heart bleed xD