MQTT_JSON device does not show up

Yesterday I added a new device to my installation but it does not show up.
I see the 4 rfxtrx lights on the card but the MQTT one is not there, nor can i find it on the dev-state screen.
I’ve restarted the container twice and the pi once. No change.
Anybody know where to look next?

Config part:

      - platform: mqtt_json
        name: "Printer"
        state_topic: "lights/3dprinter"
        command_topic: "lights/3dprinter/set"
        brightness: true
        flash: true
        rgb: true
        optimistic: false
        qos: 0
      - platform: rfxtrx
        automatic_add: False
            name: Woonkamer Voor
            name: Woonkamer Achter
            name: Drakenlamp
            name: Wandlamp Computerkamer

I just tried your configuration and it works fine on my system. Sending it a state of on results in this on the developer tools state page

light.printer 	on 	brightness: 255
                                min_mireds: 153
                                max_mireds: 500
                                hs_color: 0,0
                                rgb_color: 255,255,255
                                xy_color: 0.323,0.329
                                friendly_name: Printer
                                supported_features: 57

Thanks, so now I know that the configuration is valid and should work.
I searched for troubleshooting steps but found nothing, did find a manual page for enabling logging, will enable that to see if that has any hints as to what is going wrong.

I got it fixed :slight_smile:
I thought the log under the system menu was the only kind of log.
But after putting logger: in my config i found an sqlite3.DatabaseError: database disk image is malformed error.
Deleting home-assistant_v2.db and restarting fixed the issue.

1 Like