Mqtt mosquitto server ip

I’m having trouble setting up the mosquitto server on other devices. I’ve added it as an integration and can send and receive via the developer tools panel but I can’t seem to set it up using other devices. I think the problem may lie in the server address I’m putting in but nothing I can think of seems to work? Any guidance on how to find this out? I have home assistant running on a Linux server laptop in docker if that makes a difference. Thanks in advance

Are you using internal broker?
It is deprecated and may stop working. I think you must use external broker.

The integration is for connection to external broker.
What device you install on?

I’m using the official mosquitto broker addon from the supervisor page. It’s working as I can publish and receive from the developer panel, just can’t figure out the server address to use for external devices to connect to it!

IP is same as host IP
port 1883

If you go to the addon in supervisor there are ports at the bottom of page.
if those ports are empty that will mean the are disabled. Make sure something exist there

What do you mean “setting up the mosquitto server on other devices”? You only need one mosquitto server on your nework.

Sorry, not the server but the settings on other devices to connect to the home assistant integration. Like join and mqtt beacon apps.

Just use the IP-address of your HA instance, and the user and password you configured for the HA mosquitto add-on.

1 Like

Ok thanks. I hadn’t configured any logins so was just using my home assistant login, maybe I’ll add one just so I know that’s not the problem. Also I’m guessing this is the internal ip? As in 192.168 1.105? If I want to use the external IP I have to forward port 1883 yes?

Better use the internal ip. No need to go outside for an mqtt connection.

Really? You want to expose mqtt to the internet. No. Just No.

Ok, so if I’m using it for presence detection using an ibeacon it just uses the lost packets to know I’m away rather than having to send a message when I’m out of range of the ibeacon?