MQTT Room Presence with room assistant: too many messages

I’m trying the MQTT Room Presence component with room assistant ( ), for BLE detection. Unfortunately, it seems to send a lot of updates with distance changes. It sends at least one per second, sometimes more. I really only need it to send an update every 5 seconds or less.
Any way to achieve this?

“room-assistant” is a client for Home Assistant MQTT broker, so the update rate is related to room-assistant configuration, and not to HA.
To achieve a low update rate, you have to contact the room-assistant developer.

Yeah I know, thanks.

I’ve submitted a pull request for that a while after posting here :slight_smile:

How did you solve this ?

Check the “update_frequency” option for the BLE tracker on the github page.

1 Like

how does this work for you? do you mind sharing your setup?