MQTT to Kodi Automation stopped working

Hello, my automations that i configured in order to control my Kodi via Infrared through MQTT suddenly stopped working.
I have a Tasmotized Sonoff Basic with an InfraRed receiver connected to the GPIO port 14. The IR codes are sent via MQTT to my Mosquitto Broker running on my Hassbian. The MQTT commands are supposed to trigger an automation on my Hassbian which calls a Kodi Method.
It worked perfectly until I updated my Tasmota to the last version (6.7.1) and Home Assistant to the last version (0.101.0), then it suddenly doesn’t work anymore and I don’t understand why.
MQTT logs from Tasmota:

21:42:40 MQT: Attempting connection...
21:42:40 MQT: Connected
21:42:40 MQT: tele/RedStars/LWT = Online (retained)
21:42:40 MQT: cmnd/RedStars/POWER = 
21:42:40 MQT: tele/RedStars/INFO1 = {"Module":"Sonoff Basic","Version":"6.7.1(sonoff)","FallbackTopic":"cmnd/DVES_65CCF5_fb/","GroupTopic":"sonoffs"}
22:13:44 MQT: tele/RedStars/RESULT = {"Time":"2019-10-31T22:13:44","IrReceived":{"Protocol":"PANASONIC","Bits":48,"Data":"0x40040100ACAD"}}


- id: '1566813139052'
  alias: IR Channel Down
  - payload: '{"IrReceived":{"Protocol":"PANASONIC","Bits":48,"Data":"0x40040100ACAD"}}'
    platform: mqtt
    topic: tele/RedStars/RESULT
  condition: []
  - data:
      action: channeldown
      entity_id: media_player.kodi
      method: Input.ExecuteAction
    service: kodi.call_method

I tried to trigger just the Kodi method and it works perfectly (PVR Channel Down)

What else can i do to debug and solve the problem?

Tasmota sends the payload (i blame the tasmota update)


and your trigger triggers on payload


You cannot trigger on the sent payload, because it has a timestamp that changes.

Maybe trigger on every payload on the topic and filter the payloads with a template condition.

trigger.to_state.IrReceived == {"Protocol":"PANASONIC","Bits":48,"Data":"0x40040100ACAD"}

or something.

You have to play and test with this.

So if i rollback to tasmota 6.6.0 it would be fixed?

Maybe. If it worked before the tasmota update, give it a try.