MQTT Unable to open include_dir


Using and used the MQTT add on.

Getting this error message

Error: Unable to open include_dir ‘/share/mosquitto’.
Error found at /etc/mosquitto.conf:19.
Error: Unable to open configuration file.

How do I navigate to these files, or whats the solution

Re Dave

Set active to false under the customize section of the addon’s options.


Just had the same problem. I’m on a self installed hassio amd64

I added a mosquitto directory to hassio/share/mosquitto and it got me past the error.


“active to false” did it, thanks for the reply

I installed WinSCP, so can now see all files & folders.

Regards, Dave

1 Like


So what does active mean in this context? Just wondering why setting it to true is a problem. I don’t see anything in documentation tab.

If set to true additional configuration files will be read, see the next option.

I.e. if it’s true then the files/folders you list in the next two options have to actually exist or you get errors like what is shown above. If it’s false it doesn’t matter what’s in those options.