MQTT, with ssl, failure after updating 0.78.0 --> 0.79.0

After updating to 0.79.0, my MQTT (with self-signed ssl certificate and user/password authentication) is broken. I use the Home assistant installation in Python virtual environment with MQTT broker installed on the same Raspberry Pi.
I also use this broker with Node-Red and connection to other IoT devices without problems. Problem occur after the mentioned update.

After some investigation I noticed on my MQTT broker topic SYS/broker/log/E an error:
OpenSSL Error: error:1408F10B:SSL routines:ssl3_get_record:wrong version number

Can anyone confirm this or help me out to get it working again?


1 Like

Not directly related, but I noticed that after upgrading to 0.79 all my MQTT devices no longer show up (light, door lock, etc) The automations around them remain, but i no longer see entities for my light and lock.k;

Had the same here, only a part was missing. I rebooted my RasPi and the devices showed up again.

I also noticed they have added Integrations for MQTT, even tried that, but didn’t get this to work (missing encrypted options).

Can anyone give me a direction where/what/test/search for?

Yep, screwed mine too but I don’t use SSL for MQTT. In the log for the MQTT hassio add-on I can see it load and devices connect OK, then it just comes up that the service has stopped, nothing more helpful than that.

Wound back to 78.3 and all good again.

It looks like we are not the only one:

Doh, did a quick scan of the forum like I always do before any update and there wasn’t anything at the time.