Msg payload: undefined

The HA system was running ok but I needed to do some updates in Node-Red because I got some flows not working due to unknown nodes. But in the process I managed to do something wrong. Now I can’t go back even if I got a snapshot stored and loaded.
All my motion sensors (aqara, zigbee, deconz) are reporting msg-payload: undefined. The log say “Communication send error: Error: WebSocket is not open: readyState 2 (CLOSING)” but I do not know if it is connected to the problem or something else.
Can someone please point me in the direction to what can happened?
Thanks // Fredrik

Restart nodered and post the logs from nodered. This assumes that the state of the sensor is available in HA just not in nodered. If it shows in neither, then it’s not nodered.

15 Jun 08:35:17 - [info] Node-RED version: v1.3.5
15 Jun 08:35:17 - [info] Node.js version: v14.16.1
15 Jun 08:35:17 - [info] Linux 5.10.17-v7 arm LE
15 Jun 08:35:19 - [info] Loading palette nodes
15 Jun 08:35:39 - [info] Dashboard version 2.29.1 started at /endpoint/ui
/bin/sh: /opt/node_modules/node-red-node-pi-gpio/ not found
15 Jun 08:35:41 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
15 Jun 08:35:41 - [warn] ------------------------------------------------------
15 Jun 08:35:41 - [warn] [node-red-contrib-wled3/wled2] Type already registered
15 Jun 08:35:41 - [warn] ------------------------------------------------------
15 Jun 08:35:41 - [info] Settings file : /etc/node-red/config.js
15 Jun 08:35:41 - [info] Context store : ‘default’ [module=memory]
15 Jun 08:35:41 - [info] User directory : /config/node-red/
15 Jun 08:35:41 - [warn] Projects disabled : editorTheme.projects.enabled=false
15 Jun 08:35:41 - [info] Flows file : /config/node-red/flows.json
15 Jun 08:35:41 - [info] Server now running at
[08:35:42] INFO: Starting NGinx…
15 Jun 08:35:42 - [info] Starting flows
15 Jun 08:35:45 - [info] [wled:QuinLED-Dig-UNO] wled
15 Jun 08:35:45 - [info] [wled:QuinLED-Dig-UNO] wled
15 Jun 08:35:45 - [info] [wled:QuinLED-Dig-UNO] wled
15 Jun 08:35:46 - [info] [wled:QuinLED-Dig-UNO] wled
15 Jun 08:35:46 - [info] [wled:QuinLED-Dig-UNO] wled
15 Jun 08:35:46 - [info] [wled:QuinLED-Dig-UNO] wled
15 Jun 08:35:46 - [info] Started flows
15 Jun 08:35:46 - [info] [server:Home Assistant] Connecting to http://supervisor/core
15 Jun 08:35:47 - [info] [server:Home Assistant] Connected to http://supervisor/core
15 Jun 08:35:48 - [info] [server:Home Assistant] Connecting to undefined
15 Jun 08:35:48 - [info] [server:Home Assistant] Connected to undefined

It doesn’t show any real problems. Where did the websocket error show up? Can you post the state of one of the sensors from dev tools. Also open one of the home assistant nodes is there more than one server entry here?

You could also try setting the debug node to complete message object instead of just payload.

Thank you very much for your help @Mikefila, I will try to answer your questions:

I have 2 servers but non is working.

I tried a basic solution now. Removed the node and added it again and then it worked :slight_smile:
It looks exactly the same but for some reason it just works now…