Multiple Dashboard - Choosing the Default?

Since 107, we now have the option for multiple lovelace dashboards, but so far something has eluded me…

I’m using Dwains theme, and also the default generated lovelace - now currently HA seems to pick the generated page as my default on any new machine I login to.
I can go into the dashboard configuration page, and click ‘Set as Default’ for the Dwains theme page instead (since this is what I want).
But obviously any new device I login to I’m back to the generated page until I change the default again.

Is there any way to pick a real default, so that it will always be used unless i’ve gone into the Dashboard configuration page and overidden it for the particular device?

1 Like

Not as far as I know. I’ve been having to go into configuration / lovelace dashboards and set the default on every device I use.

It would be nice to be able to set the default per device type (mobile or desktop). Though I don’t know how possible that is. Web developers don’t seem to have an issue doing it for websites.

Interesting… seems a bit of an oversight not being able to pick the ‘global’ default so to speak, as it means having to constantly override it on each new device if it isn’t the one you want.

I guess the only thing I can do at the moment it effectively disable multiple dashboards and go back to just having Dwains theme, so it’s the only option, and therefore the default.

There’s an option on your Profile page (last item in sidebar) to “Pick a default dashboard for this device.”

I just leave mine on default, so I don’t know exactly how that works. But that might be something you could try.

1 Like

Emphasis mine.

What would make things a lot easier is if there was a set_default_dashboard service. Then I could add buttons to do this on my dashboard’s home view. At the moment my guest account has the sidebar hidden (custom header) so the user can’t mess with settings but this also means they can’t set a dashboard default.

As a workaround at the moment I have buttons that will navigate them to my mobile or desktop desktop dashboards but they have to do this every time they open Home assistant.


Thanks, I think I’ve tried it before… but will double check later.

The issue is as you say it’s picking a default for “this device” not any future device, so every new device login it needs to be done again.
It would be more useful to allow a choice for default on all future devices too, unless overridden by a new choice on a specific device. (Hope that makes sense) :grin:

Even after reading these posts, I’m still confused.
I’ve created a new user, and when I log on as that user, and select a custom dashboard, it still falls back to the default dashboard every time I log on again - from the same device. It does remember the “Always hide sidebar” setting, but it doesn’t seem to remember the dashboard setting.
Is this a bug, or by design?
I’m running HA Core 0.115.2 in Docker.

1 Like

I’m getting the same behavior. Default ALWAYS reverts to the original dashboard.

Sounds like a bug to me.

Possible this behavior is seen because the “initial” dashboard is somewhat confusingly named “default_view” - even when it is not the default view, that’s still it’s name…

i.e if you set a different default, but go to the “ip/default_view” url, it will take you to the “initial default”, because that is it’s name. Confusing? yes lol

Try: http://homeassistant.local:8123/

and not


@Tahutipai Confusing indeed! But ultimately not the cause of the problem, at least in my case. What solved it for me was allowing my browser to retain cookies for http://homeassistant.local:8123/ and not just http://homeassistant.local/. In other words, I had to make sure that I included the port number along with the .local domain in order to get the browser to hold the setting. Once I did that, the default remains at where I set it!

Old thread, but in case anyone else stumbles upon it and wants a solution :

  1. Create a dummy file in /config called “ui-lovelace.yaml”. If this file exists it is what is used for the default dashboard.
  2. Make this file only one line :
    !include "/whatever/your/desired/default.yaml"