Multiple Modbus Hubs from HA 0.88.0

I have recently tried using HA 0.89.2 and 0.90.0 to test the functionality of the new implementation of multiple modbus hubs (since 0.88.0).

I have tested both 0.89.2 and 0.90.0 and found that while modbus sensors and modbus switches work perfectly modbus binary sensors are not.

On startup the error message is:

Invalid config for [binary_sensor.modbus]: expected int for dictionary value @ data[‘coils’][22][‘coil’]. Got None. (See /config/configuration.yaml, line 1268). Please check the docs at

I have raised an issue here but I was hoping to get feedback from anyone else having problems with the new multiple modbus hub solution.


Modbus Binary Sensor Problem Resolved

Problem Found:
One of my binary sensor configs contained no entry for the coil value. Once that was fixed around 100+ binary sensors (in three separate hubs) commenced working and the error disappeared from the log.
May be one to remember for admins helping with modbus binary sensor issues in the future.

HA Version: 0.90.0

UPDATE: 0.91.0 write register problems solved

On creation of a new QNAP container just now with the new version 0.91.0 and testing all functions are as expected I found that it appears that writing to modbus registers has been fixed?

I looked here and could not find anything that would indicate work having been done on the problem I was having IE: not being able to write to modbus registers. In any case the problem appears to be resolved for me (with zero config changes) so thanks to anyone who may have tidied something up that was causing the problem.