Multiple Z-Wave controllers?


Completely new to HA, but have acquired 1 RPI with Silicon Lab UZB-7 stick (SLUSB001A) for testing purposes. My plan is to evaluate HA and possibly migrate existing Domoticz installation (2022.2) running on RPI with OpenZWave USB (actually an old Z-Wave.Me top from 2016) running 24 Z-Wave nodes.

Looks as if the HA installation is ok. Silicon Labs stick has been upgraded to 7.18.8 firmware. Have added Z-Wave JS UI (3.4.2) and I’ve removed Z-Wave JS which I after some googling discovered was not needed.

I’m trying now to include a Fibaro Motion Sensor (FGMS-001) but unfortunately the inclusion times out.

Is having 2 Z-Wave controllers within the same area ok even if both would run as primary controllers? The network they control is different so I’d assume they don’t interfere with each other?

Any way to see if the UZB-7 stick is actually trying to do the inclusion? Z-Wave statistics shows a lot of Message TX and RX. All other counters is 0.

Per W.

Running multiple Z-Wave controllers is perfectly normal. I run 3 in my environment.

Have you tried excluding or factory resetting the device? Even from the factory devices may be included into a network. If that does work verify the region on your controller is correct.

Thanks for your reply. I can’t find it in the old Domoticz network, nor does exclusion from that network seem to have any effect. RF Region is set to Europe.

Yes that is fine, but even though Z-Wave has longer range and is not as sensitive to EMI/RMI/EMF interference as other IoT protocols (such as Zigbee/Thread/Bluetooth) you should still take actions to avoid keeping the Z-Wave Controller close to sources EMI/RMI/EMF interference as well as make sure you have enough Z-Wave repeaters on the network before adding battery-powered devices.

So a general tip is to begin by connecting the Z-Wave Controller via long USB extension cable to get it away from any other electronics or things with electrinicity which might be a source of EMI/RMI/EMF interference (including the computer running Z-Wave JS). For Z-Wave is is normally OK to not use a long USB extension cable with the Z-Wave Controller once you added enough Z-Wave repeaters on the network to extend range and coverage.

Otherwise the best practice tip for any mesh networking based technology is to always begin by first adding mains-powered Z-Wave products that act as Z-Wave repeaters, starting at locations close to the Z-Wave Controller then working your way out as the network mesh is built out.

I originally tried upgrading from an Aeotec Z Stick Gen 5 (Z-Wave 500) Controller to an imported Silicon Labs UZB-7 USB Stick (Silabs SLUSB001A / SLUSB7000A) myself a few years ago and got the same symptoms, but at that time I ended just buying an Aeotec Z-Stick 7 (Z-Wave 700 Controller) which had just been released then. Later I however learned that there have been issues with some firmware updates resetting “RF Region” and “TX Power Level” settings on Z-Wave 700/800 controllers. It will not work if those are wrong or way off. So several other people got it to work find with those configured correctly for their RF regions.

So recommend that you doublecheck that it still have the correct “RF Region” and “TX Power Level” settings is configured after any firmware update, (you can for example check with , and I believe “TX Power Level” default should be around 127 dBm for Normal and 0 dBm for Measured in Europe for Z-Wave 700/800 controllers).

FYI; there are more discussion about that and the Silicon Labs UZB-7 USB Stick dongle specifically here:

Be aware that there is currently a bug in all current Z-Wave Controller 7.19 - 7.21 firmware, so good thing that you did not update to anything later than 7.18 for now. See/follow that FW issue here:

Just to conclude - I’ve now managed to include the Fibaro Motion Sensor. Placing it 5 cm away from the controller made it discoverable. Thanks :slight_smile: