Multiple z-wave sticks failing validation

I recently began setting up HA on a pi4. I used the HA custom image and so far like the UX. I am now wanting to add a z-wave controller so that I can begin moving some of my devices off of my HomeSeer setup onto HA. This is where I have hit a wall.

I have tried adding two different USB controllers and both fail validation when adding the z-wave integration. The first stick I tried was the nortek dual z-wave/zigbee stick. After it failed to add repeatedly I found that it was not technically supported. So I ordered one of the sticks and tried to get that going and it fails validation the same way the nortek stick did. I have been searching the net for days and have found lots of troubleshooting info for z-wave setups on HA, but nothing to help with when the USB is failing validation and not getting passed step 0.

The really strange thing is that every single serial device that is added by either of the sticks fails validation, but the one serial device that is always there even if no stick is plugged in does get passed the initial validation and the z-wave integration gets added to HA. Then starting the network it says in the logs that the driver failed. Which at that point it should obviously fail because the path is not to a USB controller, but how did it get passed validation to begin with???

If anyone can point me in the right direction or has any idea what to look for when HA seems to refuse all valid USB paths, I would really appreciate it.

Try the nortek through a USB hub. I was having issues with mine with a pi4 and that fixed it. Try more then one hub since it did not work with 1 of the hubs I had.

I haven’t heard of the Nortek having problems with a Pi4 before. The has also been reported as compatible. The controller that is known to not work (without a USB hub) is the previous version of the Aeotec Gen5 Z-Stick.

When you inserted the USB sticks, did you reboot or restart Home Assistant? If you are using Supervised HA, the HA container will not see the USB stick if it’s already running and you insert the stick, even if the Supervisor shows it.

The usb path you want to use would be /dev/serial/by-id/usb-0658_0200-if00. What does the Supervisor hardware info show as the available paths?

Bingo! and facepalm!

The nortek controller allowed adding the z-wave integration after restarting the pi with the controller plugged into a USB 2 port. Really glad I decided to ask the experts before buying a third stick to try! The supervisor showing the hardware but not being available to the HA instance really threw me. Thanks a ton @freshcoast.