Multisensor showing only as one "binary_sensor" after upgrade to 0.88.1

I upgrade from (I think) .86 to .88.1, and I’m now having a problem with my Aeotec Multisensor 6. When I first added it to my controller (before upgrading), it properly showed up as a variety of sensors (humidity, temperature, etc). After the upgrade, it now only shows up as one “binary_sensor”.

I’m not sure if this has anything to do with the update, or it’s just coincidental (the upgrade was probably the first time I had done a full restart of my server and therefore HA since before adding the Multisensor). After the update, I did have to manually upgrade openzwave in the virtualenv, since the HA upgrade did not do that itself.

I’m not sure what the right course of action is here. I could remove the sensor and re-add it (not sure the right procedure here). Though it definitely is still reporting, and when I push the button on the sensor, I see it go from asleep to awake, and then back to asleep (telling me that the sensor is communicating with HA and OZW properly). That all makes me think that it’s just a config issue that something was broken during an update. I’ve looked through the config files, but I’m not confident that I could change the right thing.

Does anyone have any suggestions?

Are you sure this happens because of upgrade? I have a aeotec water sensor that needed me to update the “report sent type” Config before it would activate the binary sensor. I’ve also read a number of posts that suggest that binary sensors sometimes don’t work. As a workaround you can write a template binary sensor that calculates the open/closed status based on the values from other entities that do change.

Edit: nope, op’s not talking about making binary sensors work.

I’m not 100% confident that this happened because of the upgrade. All I know is that it worked before the upgrade, and stopped working after. However, as part of upgrading HA, I also installed CentOS updates and rebooted the server, so any of those are possible causes of my issue.

One problem I’m having is that when I search for information related to the binary sensor, this appears to be a desirable thing for some people. However, I can’t imagine that this would be desirable to the exclusion of all the other sensor information.

Because I’m currently not getting any useful information from my sensor, I’m assuming that being a binary_sensor is a "Bad Thing"™, and so I’m trying to make it not a binary sensor, if that makes sense. Also, everything that I’ve seen related to being a binary sensor seems to have something to do with the motion tracking. I’m not interested in that capability, but rather need the sensor’s information on temperature, humidity, and luminescence. As far as I can tell, I’m not actually receiving any sensor data from the sensor, other than the basic zwave data.

My apologies, I misread your post and assumed the wrong thing about your need for binary sensors. Nevertheless, with my aeotec sensor too, I was getting basic set data and I’m guessing home assistant didn’t understand how to deal with it, because the binary sensor was not showing any updates. I had to go to z-wave>nodes>node config>choose 121:Report sent as type> set value as 17>update config. My theory is that even though your device is different, it belongs to the same manufacturer and perhaps more aeotec devices have the same problem. That the z-wave controller needs to tell the sensor how to send it the data so it can make sense of it, and that this config “121: Report Sent as Type” sets that format. Only a theory…

Edit: nope, this doesn’t help because op can’t even see other entities anymore.

Perhaps a picture is worth a thousand words here:

You can see that only the binary_sensor is available. All the sensor.* are showing as (entity unavailable).

EDIT: I looked for a parameter “121: Report Sent Type”, and did not see one. However, there was a “reset to factory defaults” option, so I selected that, and we’ll see what happens when the sensor next wakes up and updates.

Yes I misunderstood, again, what you were trying to say. I’ve edited my posts to mark that now. Hope you find the fix!

Have you tried manually waking up the device, to see if the sensors updates?

Unfortunately, that doesn’t work. Like I said in the OP, when I wake up the device, I can see that the Zwave device goes from asleep to awake, and then back to asleep. But it doesn’t detect the sensors (other than the binary_sensor).

Missed that, but it also doesn’t mean its communicating properly.

Try a health connectivity test.

**Testing Health Connectivity.**

Note - Health test does not test for routing communication health, only tests for direct communication with your gateway to determine if it has a healthy direct connection.
  1. Press and hold Multisensor 6 Action button
  2. Wait until the RGB LED turns into a Purple Color
  3. Release Multisensor 6 Action Button

The RGB LED will blink its Purple color while sending ping messages to your gateway, when it has finished, it will blink 1 of 3 colors:
Red = Bad Health
Yellow = Moderate Health
Green = Great Health

**Be sure to watch for the blink, as it will only blink once very quickly.**

When I do the connection test, it always comes back green.

What about manually defaulting the device?

What do you see in the States panel under dev tools?, you can filter the attributes by node_id: # (# = the actual node id of your device) which will display all the sensors associated with the device.

Ok, I’ve fixed(?) it, but it’s all super weird.

I’m currently working on adding in some other integrations, so I had another reboot of the controller (this is probably the 8th or 10th time I’ve rebooted either the server entirely or HA since I’ve been fighting this issue), and now it works. However, I’m now seeing a bunch of zwave devices as “entity not available”. I’m guess that if I manually toggle them on/off, it will fix the problem, but since I’m away from these switches at the moment, that will have to wait until later.

However, like I said, I’m now getting sensor data from the Multisensor. Because I’m feeling pessimistic, I have a feeling I’ll be back reporting one or more things broken again. Please stand by for my update later today.

And thank you all so much for your help and suggestions! HA can be scary without some hand-holding, so I appreciate you taking the time with me.


So far so good. It looks like everything is back working again (for now, haha!)