My (bad) experience with Intel NUC with Proxmox and HassOS

Hi all

when was announce that HA supervised was going to be deprecated and HassOS was going to be the (only) way to install HA on various platform, I decided to give it a try.

My hardware is an Intel NUC i3 with 16GB of RAM and an SSD with Proxmox on top of it (6.1.x at that time) and I was using Ubuntu 18.04 LTS Server with Docker and

So I have prepared a new VM using the whiskerz007 proxmox_hassos_install script.

No pain to do it and a little pain to transfer all the configurations and addons from the previous VM to the new one.
Some testing and the go with the HassOS VM active.

No problems for some days, but then something happened.
I don’t know if the issue was the concomitance of a Proxmox upgrade to 6.2 and the HassOS upgrade to 4.8, but then all my problems started.

One day restarting the VM (not HA) I’ve got this looking at the console

The VM was stuck at that stage and there was no way to solve it.
I tried to follow some thread in the Proxmox forum, but with no success,

I’ve tried to create several times new VM (always starting from the whiskerz007 install script, but then after few hours or days I’ve always got this issue.

A Proxmox snapshot was never a solution, only a VM backup could “revitalize” it.

My impression is that something is broken with UEFI disk of the Proxmox VM, but I don’t know where to look for.

I have also to say that I’ve never tried to install HA directly importing the .vmdk or .qcow2 disk into Proxmox.

In any case, today after few days passed to reinstall and reconfigure HA from previous snapshots or backups, I decided to go back to my first installation type on my Intel NUC, Ubuntu_Server+Docker+HA

Now, this is running in my Proxmox server and I’ve also noticed that the CPU and RAM occupancy is lower that HassOS. I always thought that was going to be the opposite.

I hope that some day I will give it a try, but for now I will go with the supervised HA installation.

I ran into the same issues as you did with the whiskerz007 install script. After restarting the VM, I would always get the UEFI error.

To get back up and running, I followed this guide: Supervised Install on Proxmox

And then simply restored my latest full snapshot from the Gmail backup addon. Works great now.

I think that HassOS is not the right choice if running in a Virtual environment…

I’m running the Supervised way from more than 10 days now without any issue…

1 Like