My .config folder got renamed to .homeassistant

**I just noticed that my .config folder was renamed .homeassistant. Don’t know how/why/by what. Of course it won’t let me change it back in file editor.

Any ideas? It wouldn’t be a big deal - I don’t even know when it happened - but I have an addon that points to a sub-directory of .config and I can’t modify that

This was a change made in a HA OS update. I don’t remember which one.

1 Like

When I look at the IP from my network it is still called config. Obviously the add on (Neolink) was written before this unnecessary change and for all intent and purpose the add on sees homeassistant not config. Seriously - why do they semi-intentionally want to break add ons?

I am new to using HomeAssistant and fighting this add on currently. I am able to get the add on to function the way it should and without errors. However, I am not sure about how to get it to display on my overview/homepage, as I cannot get a generic camera setup with this now. However this worked for me to get the integration without errors:

create a folder in /homeassistant/addons
add neolink.html in that folder

1 Like

I backed up to the root (/) directory in file editor and made a new folder named config (also tried .config) with a subdirectory named addons and a file named neolink.toml. I get “Error: Failed to read “/config/addons/neolink.toml”” when I try to start the addon. I’m honestly rethinking my Abu Casa support for open source. They need to stop “fixing” what isn’t broke

See this topic: Folder structure not updated with latest release

I tried that but I thought it was looking for neolink .toml which I copied there from my original Neolink application for Windows. The error says “Error: Failed to read “/config/addons/neolink.toml””. I tried putting it in directory addons from /homeassistant AND adding it to /homeassistant/config/addons

The “solution” is almost as confusing as the question. If I understand correctly, the addon developer has to change the code which means that there MUST be other addons (that reference /config/addons) that won’t currently work. I will write an issue on their Github page quoting the article linked. Thanks tom

1 Like

Are you running OS or supervisor?

Supervisor I think but I get this in “About”

I see Supervisor AND OS listed. Guess I don’t know - can you tell?
Seems like they changed HA last month so that add on developers couldn’t back door access the config directory (or something like that). I started an issue on developers Github to make them aware.

That’s HA OS (which uses Superviser).

1 Like

OK IC. That’s what I thought but sometimes I think wrong.

I apologize. I THOUGHT I had tried that but the whole “missing config folder” thing messed me up - that and “neolink.html”. With addon sub-folder added under homeassistant (config) folder and neolink.toml placed inside the add on starts. I will try to figure out how to get into Frigate and maybe a card in the UI. I’ll give it a day or two and post if I can, then I will close this silly inquiry

I tinkered with getting the camera into a picture entity card since I thought that would be the easiest way to integrate into the UI - it wasn’t very easy. I managed to get a “Generic camera” integration working and then selected that camera in the Picture entitity card.
Basically, add integration; generic camera; still image: blank; stream source: rtsp://{camera name from config.toml}/main; transport protocol: TCP; authentication: basic; username: (for camera); password: (for camera); verify ssl: I unchecked this. Hit submit and it should come up with a check box saying “this image looks good” - mine didn’t but I submitted anyway and it gave me an entity named “” so I changed the name. The /main after your camera name can be sub or Sub or Main - there are options at the end of the log in Neolink addon. The log also gives the camera name in case you forgot what you put in the toml file.
The first few times I clicked on the entity in the generic camera integration it came up blank - maybe reloading - and it did the same thing after I renamed it. Seems stable now. Hope this helps and thank you for your help. Please let me know if it works for you too. I will close this after I hear from you

I run supervisor and it doesn’t show a number next to the operating system field on that screen.

Which camera are you currently using? I was battling the Reolink Lumus last night but finally had to put a link in with a jpg image in to get the camera to work.

I have 2 Lumus cams and was pretty happy that I got them setup - at least on a card. I just tried to add a Yaml file to Frigate with only one of the Lumus cams/ without my IP cams and it didn’t work. Then I noticed that the Neolink Add on had shut down. I restarted, but didn’t make note of the logs except something about “by user”. After the restart it took quite awhile for the camera to appear in the integration and on the picture entities card.
I see in the Generic Camera integration that pretty much since I got it working 8 hours ago the sensor it created has been going from idle to unavailable immediately except the first time which took 13 1/2 minutes. It’s been 18 this time and still idle. The cameras seem to be counting through the seconds steadily on the clock from the camera with no glitches. Seems like it buffers in the integration, but not on the card.
Has your add on been running without the shutdown I had? I assume the generic camera integration didn’t work for you?? My HA is running on Ubuntu through VMWare on a Windows 10 PC which usually makes everything hard. I was running Neolink on the PC for Blue Iris - had a few problems there too especially after restarts - but obviously couldn’t expose that to HA/ Frigate. I shut that instance down earlier to make sure it didn’t interfere even though it’s basically on two different systems. It does provide the same rtsp ( though. Good luck and keep trying
Cams are still up and switch has been idle now for 32 minutes (and counting). Maybe trying to get the rtsp stream into Frigate while it was running in Generic camera did something, but 62 “unavailable” on the switch with very little (sometimes zero) time at idle is disconcerting.

Update: cameras ran for almost 6 hours until an “unavailable” which only lasted for 10 seconds. One of them actually had a second one 30 seconds after the first which lasted 20 seconds. Both have been up now for about 10 hours. I’m going to leave them alone for a few days before I try to get one into Frigate again.