My Danalock v3 Z-Wave Configuration 5. Step Solution

  1. You need to have this in your config. file:
  usb_path: /dev/ttyACM0
  network_key: "0x04, 0x03, 0x01, 0x07, 0x09, 0x06, 0x05, 0x02, 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10"

You can probably just copy that network key.

  1. Put the lock in inclusion mode. Either by the switch on the lock or with the Danalock app

  2. You need to “add node secure”. You do this under “Configuration” and “Z-Wave Network Management” Remember to push “heal network” afterwords.

  3. You need to toggle “get_usercode” Do this under “Developer tools” and “Services”. This step also requires inclusion mode.

  4. Calibrate the lock using the Danalock app if necessary. Maybe upgrade firmware


Sorry for asking the question in this thread aswell:

Exactly how do you toggle “get_usercode”? With the service on the lock-entity?
If that is the case: With JSON-data like the following?
“node_id”: “51”,
“code_slot”: “1”

Do you initiate inclusion with a single click in the pin hole on the lock itself or via the Danalock App?

And a last question: What firmware version do you run on the lock?

My post is updated


Thanks for sharing your setup steps.

But I am not able to make it work.
After step 3 I see zwave.polycontrol_danalock_v3_btze_7, but I am not able to lock/unlock it.

When I call get_usercode, I do not get any code back. Should I?
Can I use “code_slot”: “1”, or which code_slot should be used?

Do I have to call set_usercode?

Do you use the app or the button on lock to activate inclusion mode?

Any other tips?

How many HA-entities appear after your secure inclusion?
I had success with setting the Danalock up with Bluetooth and then including to Z-wave with the clip-hole button. The pins don’t need to be configured for lock/unlock to work, but you do need to toggle the “get_usercode” service with the lock in inclusion mode after the initial secure inclusion.

@KKlitgaard: Thanks for answering.

I get two entities after call “get_usercode”:

But I am still not able to lock/unlock the lock

So you don’t have any sensor.polycontrol_danalock_v3_btze_alarm_level_5 or sensor.polycontrol_danalock_v3_btze_alarm_type_5

I experienced that keeping the unit alive (by hitting the clip button regularly) and having less than 20 cm between the unit and my Z-wave stick in the RPi during the secure inclusion made more entities appear.
The pairing of course requires a total removal of the Z-wave node if paired previously :slight_smile:

I have tried several times now, but still not succeeded.

No, I do not see any sensor devices.

Is calling “Remove node” when the lock is in inclusion mode good enough?
I have also tried to reset the device.

have you managed to get i t to work?

No, I have tried many times :frowning:

After pairing I get this warning:
[homeassistant.components.zwave] Z-Wave entity Unknown Node 30 Locked (node_id: 30) not ready after 30 seconds, continuing anyway

Any suggestions?

Have you installed the latest firmware and tried keeping the device alive (hitting the clip button every few seconds) during the secure pairing?

No it is not working for me. i do not get the message you do

Danalock V3 … my dirty lock :smiley:

I can feel your problems … It took me a lot of effort to make it work

Following steps work for me:

First I put the old firmware 0.7.9 on the device via “nRF Toolbox”

After this the following steps:
1.) reset the device (click 10 times the button - it should blink red)
2.) wait a minute
3.) hit the button 1 time (it should come a green led - not blinking)
4.) after a few seconds it starts blinking green -> “add secure node” in HA
5.) wait and done

Just to clarify: I had succes pairing with the 0.9.6-firmware.

howe long did you keep it alive?

when you remove and try again, are the old on still in z-wave intergations?

From the blue box here: Z-Wave - Home Assistant

If you change the usb_path or network_key in your configuration.yaml then this will not be updated in the integration. You’ll need to remove and re-add the Integration for these changes to take effect.

I think I have not been able to add a network key, so I probably have to re-add all my devices with after adding a network key

or just the integration?

i did just remove the danalock and remove the integration. then i restartet and added the lock and it works :smiley: thanks for the tip
i had the same issue as you

Great, so you just removed zwave from the config yaml, and added it again from the frontend?