My Danalock v3 Z-Wave Configuration 5. Step Solution

Well I haven’t anything in the configuration.yaml, I’m using the integration. I couldn’t make it work back when I tried with the configuration.yaml, but with the integration, and doing the steps carefully it works perfectly here.
I, of course, do not have the same stick, so there might be other issues at hand here.

1 Like

GOT IT !!!

Another try like fribse did My Danalock v3 Z-Wave Configuration 5. Step Solution
and now it’s perfectly integrated

The time before i used the same danalock with a raspberrian module and z-wave.me
Now i switched to HA in combination with a Z-Wave. Me ZME_UZB1 USB Stick

I’m also use the ozwave integration
And be sure you take the correct USB_PATH if you have another usb hw device on your device
I don’t recommend the generic:

usb_path: /dev/ttyACM0

because it’s easy to failure if you have more hw connected°!

1 Like

Great!! It was exactly what I needed.
The last note about putting the lock in inclusion mode “AGAIN”… that was all that was needed.
And during this pressing the lock.get_usercode …

Thanks.

1 Like

My I ask your help please? I cannot set up my Danalaock v3. I use Aoteck Z-wave 5GEN usb stick. I tried to add with integration and tried via configuration.yaml also. I see my device but I cannot lock or unlock it. I made the lock.get_usercode process also. Please help me! Thank you!

Thanks for this! I had no idea that step 4 (get_usercode) was important…

I can confirm that following these steps works.

Call service “lock.get_usercode” with service data: (Look up your locks node_id and replace 7 with in this data below).

{
  "node_id": "7",
  "code_slot": "1"
}

Does’t seem to work for me. Do I need to get a reply? I am not getting any response when sending this command.

No there’s no reply.

Am I doing something wrong?

  1. select add secure node in HA
  2. Add the lock by pushing in the small pin on the lock (I also tried with the phone app)
  3. wait a bit
  4. do a get_usercode
  5. heal the network

At the second step wait until you see that node is completed and after do the get_usercode process.

I made a video showing what I tried. It can be downloaded together with the log from https://send.firefox.com/download/e93e17cab50c28e4/#XqgHDZgA5gUgq_7gdqP25g

Danalock Support just told me that my z-wave usb hub doesn’t support doorlocks. (Aeotec USB Z-Stick - Z-Wave Plus)
Which stick are you guys using?

They are supported, their support team is under educated.

1 Like

I’m using AEON Labs ZW090 Z-Stick Gen5 EU, works great.

I’m also using AEON Labs ZW090 Z-Stick Gen5 EU, and can confirm that it works perfect. Lock/unlock as well as adding usercodes to the Danapad. The Danapad doesn’t show up yet, but they’ve promised to add support for Danapad as well.
I couldn’t get the service call to work in HA though, so I had to set usercodes via z-wave admin UI.
I never did the “get_usercode” step, so that’s not necessary to get the lock working.

When adding the lock I took it from where I originally mounted it and did the inclusion near the z-wave USB dongle. After successful inclusion I installed the lock at the final location, did an auto-calibration, and finally a “Heal node” (+ inclusion mode on the lock to wake it up).

Super happy with the lock after having used it extensively for several hours :slight_smile:
It definately suits my need for my AirBnB cottage.

What do you mean with “The Danapad doesn’t show up yet, but they’ve promised to add support for Danapad as well”?
Who promised to add support for Danapad?

Can you see who unlocked the lock in homeassistant with the Danapad?

I thought it would show up in HA as a separate device, but that’s not the case.
Atm you need to send user codes to Danalock via the z-wave UI in HA directly, and the codes work from Danapad. I guess that means OZW has support for user codes.
Hopefully there will be a proper UI for it in HA as well as a way to use it in automations.

I think Danalock syncs the user codes with Danapad. At least it looks like there’s a sync when I manage the Danapad in the Danalock app.

I can’t see who unlocked the lock (besides HA) in HA.

There’s posts you can follow to implement lock code management:

Hi,
I am quite new to this HA and Z-wave setup. But I have spend a lot time the last couple of weeks.
I can see you got it to work, which gave me hope :slight_smile:

I have tried so many things, but to be honest, I am doing it blindfold, as I don’t know what and how exactly to do it. I have managed to get a node called “Poly-control Danalock V3 BTZE Locked” in my Z-wave node management and some data.

But no matter what I do i cannot lock or unlock the Doorlock? :frowning:

Are you able and willing to help me get it to work or direct me to a guide?

Br.
Daniel

hi all

bit hit and miss for me too. I got a brand new Danalock v3, updated the firmware to the latest 0.16.0, managed to connect to HA over zwave fine, and even managed to set usercodes in HA.

However, when I had to reset everything, reinstall HA, factory reset the Danalock v3, had “remove node” in HA prior to any actions, removed the Danalock v3 from the app, basically started completed again, it will no longer show the “usercode” sensor so I can’t actually set/get any user codes anymore.

It does still lock and unlock in HA absolutely fine, but usercodes is missing.

I’ve repeated the “factory reset” of everything numerous times too.

Incidentally, the Call service “lock.get_usercode” with service data method still doesn’t add it back in.

Any thoughts anyone?

TIA

Do not post your network_keys in public. Do not use “default” network_keys. Create your own. It should be a password for Zwave Security.