My experience, so far

So, I finally caved, found and old dusty laptop, with the intention of setting up Home Assistant, and to my pleasant surprised, I quickly found out that HAOS is a thing. Yay, no need to install Linux first, messing around with docker, virtual machines and God knows what.

Well, that’s pretty much where the pleasantries ended.

I spend some time, looking for a download link, to no avail, but found the official guide, which told me to install some hitherto unheard of software, in order to perform the simple task of flashing my USB stick. Well, being pretty tired already, I just did as I was told. +100MB for at piece of software to flash an USB stick? DD under Linux, takes up less than 100KB, and performs the exact same task, though it does not have the ability to fetch the image from the net, I think, nor does it entertain you with commercials, while waiting, but I digress.

Having downloaded and installed this monstrosity, again, I did as I was told, and of course it failed, again and again and again. The USB stick was broken, it seemed. I tried to fix it on my own, but to no avail, so I dragged Google into the discussion, quickly found a relevant blog post, promising to have the remedy for my unfortunate situation, so I spend some time on that, which of course didn’t help, at all.
So, I did the only thing one can do, in a situation such as this. I dragged out yet another old dusty laptop, a Linux Laptop, booted it up, wrote a new partition table, after which there were no issues.

Finally, my troubles were over. All there was left, was to plug it in, and let it do all the hard work, but alas, it turns out, that it is not, in fact, an installation medium, which means that I am now short one USB stick, which is even very ill suited for the purpose it is now serving, but hey, at least it was working…

Well, not so much. Apparently WiFi isn’t really a thing, which meant I had to find an ethernet adapter for the Laptop, as it doesn’t have build in ethernet. This might very well have been the end of my story, as the one ethernet adapter I knew I had, somewhere, that came with the laptop, God knows how many years ago, has never actually been used, and has been on the move several times since then, but damn it, I found it!

Now, that had to be the end of it. I mean, what on earth could go wrong now?

Well, it is not 1:30, and Home Assistant is still preparing, for up to 20 minutes. What on earth it is preparing for, I cannot say. I mean, I am, though it may not sound like it, a reasonable tech savvy guy, and I cannot for the life of me figure it out. I fear it is plotting for world domination, but if it is indeed something more benign it is doing, I am particularly curious, what it is.

Any ideas?

Now, I know this may all sound very negative, but that is not actually my intention. Believe you me, I have tried far worse, but it is important to tell these stories, if there is to be any hope of improvement, and while I am as big of a noob as one can be, when it comes to Home Assistant, never actually having used it, I can say for sure, with no hesitation, that it is in dire need of improvement.

Best regards.

1 Like

You are right - HAOS is a pain to install, but assuming you actually read the instructions you were warned. From the install page:


You will need to write the HAOS (Home Assistant OS) disk image directly to your boot media, and configure your x86 to use UEFI boot mode when booting from this media.

And further down:

As a next step, we need to write the Home Assistant Operating System image to the target boot medium. The HAOS has no integrated installer. This means the Operating System is not copied automatically to the internal disk.

Lastly it sets out the recommended way of installing on non-removable media:

  1. Copying a live operating system (e.g. Ubuntu) onto a USB device. Then, insert this USB device into your x86-64 hardware and start the Ubuntu.

And I agree that this is long winded way to do things - but the correct instructions were there.

HA is a community maintained open-source project - and I guess no one in the team has the time or knowledge to write an installer for all the supported hardware. I am sure if you try again and install it correctly you will find it a very flexible and useful system - especially compared to other home automation platforms.

All this said, you can get HA docker install up and running in under a minute.


All assuming you already have an OS and Docker installed - yes :slight_smile:

Ubuntu or debian adds 30 minutes maybe but yes…OS and docker needed :blush:

All joking aside i remember some 5 yrs ago trying to get up and running with openhab and I couldnt even figure out how to get that going. I found HA shortly after and had it running, setup and was using it within an hour (docker)…the setup time was all me learning to use docker for the first time on synology which made it more complex.

HAOS is a bit if a pain to get running. Not sure why. Docker is much easier and although you dont have addons i feel theres more flexibility.