My Grid Consumption Sensor is off by /10

Hi all,

maybe someone can help me. I added my Solar System and my Power Meter to HA.

I was able to add my KWH from my Solar via the Riemann Integration. All works fine (I can double check it with another app and compare the data)

For the Consumption I added the Offpeak/Onpeak Utility Meter … that worked also well.

My problem is the Utility Meter (Consumption) is off by *10

it tracks 0.46 kwh see in the screenshot but in reality it is 4.6 kwh

Is there any way to multiply the Utility Meter data by 10? I am a bit lost I found some topics to this multiply a value but I also can’t modify the utility meter with yaml it seems?

Thanks if someone has a good tip.

What does your utility meter helper configuration look like?
Is the unit of measurement set the way you expect?

Yeah look like yours and kwh is also right to be honest just the output should be 9.99 not 0.99 kwh

I tried other outputs but they all end up at 0.99 KWH as well if you calculate them.

Or can I do there something else? I tried a bit there as well but changing the measurement there didn’t helped? It’s really off by a 10 multiplier

Is the source energy sensor giving the correct values?
I’m not familiar with the Riemann sum integration or why you might use that instead of the raw solar sensor but i wonder what the utility meter (or another one as a comparison) would look like if you base it on the raw sensor?

Consumption Side:

I mean the number is 100% correct it’s just off by 10 , so how can I multiply this sensor by *10 so it tracks the correct number.

Right now it tracks 0.99 KWH but in reality today I used 9.99 KWH

maybe someone knows that because I didn’t find a way to modify the utility meter helper and I didn’t find a way that was logic to me to create another helper that modifies by 10?

No Riemann sum integrator needed.


As you mention the Riemann Sum integrator, my solar inverter sends the data in Watt. So to calculate the KWH you can use the Riemann sum integration. Problem solved. The Solar side is not the problem :slight_smile:

Solar Production 12-1pm is 4.1 kwh → correct

Energy Usage (Consumption) 12pm-1pm is 0.47kw → wrong should be 4.7kwh

Maybe you could, as an alternative, create a template sensor that multiplies the original sensor by 10. Something like…

{{ (states('sensor.inverter_gw5000l_dt')|float * 10) }}

Thanks will try this

Using method: left?

Oh, I see.

Yeah the Riemann left integration works well and reports my Solar Output perfectly.

I did now a custom template helper with sensor. Added the *10 … then I needed to add also the energy entity and state class like explained here Frequently Asked Questions about home energy management - Home Assistant

Now I wait 1-2 hours and see the results. Looking good so far lets see in 1 hour :slight_smile:

Really weird why the sensor reports like that seems to be some integration problem with the Huawei Solar Integration getting the data because on the FusionSola App from Huawei it reports the right way without having to multiply it by 10