My HA does not recognize Sonoff dongles (E+P) correctly

Hello everyone, I use the following HA config

Core 2024.5.5
Supervisor 2024.05.1
Operating System12.3
Frontend 20240501.1
(i.e. current)
On a Raspberry Pi 4

Two weeks ago I bought a Sonoff Dongle E to use ZHA or Zigbee2MQTT.

Unfortunately my HA only recognized a serial device and not that it was from Sonoff.
I have tried several different FW versions (Webfasher Silabs) and original Coordinator FW versions with SecureCRT and XMODEM but HA only ever recognizes a usb-1a86_USB_Serial-if00-port0. to ttyUSB0 which can be specified, but probably cannot be initialized. Both ZHA and Zigbee2MQTT cannot connect or start.

I saw in screenshots from other users that they…
ls -l /dev/serial/by-id the output:
usb-Silicon_Labs_Sonoff_Zigbee_3.0_USB_Dongle_Plus_0001-if00-port0 → …/…/ttyUSB0 is coming.
For me, the dongle E always only gave me:
usb-1a86_USB_Serial-if00-port0 → …/…/ttyUSB0 (or something similar)

Then I got a dongle P, since the dongle E is only experimentally supported and what can I say, exactly the same game.

The output should probably be with ls -l /dev/serial/by-id:
usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_88a22df07c29ec119cf76d7840c9ce8d-if00-port0 come and I only get:
usb-1a86_USB_Serial-if00-port0 → …/…/ttyUSB0 (exactly this time)

Could it be that a driver is missing or not loading?

The dongle P is still completely original, without me having tested it with different FW versions. And according to Sonoff it should have Coordinator 3.x on it (which I can’t verify either.)

Oh, my Raspi is in a Deskpi case and I have loaded a Deskpi serial driver for the temperature-dependent fan control. Could this possibly have a disruptive effect on the dongle? Edit: i uninstalled the deskpi Addon and the problem persists.

Does anyone have a tip for me?

Thank you, greetings Bernd

Did you try a different USB-2 port ? Or a powered USB-2 Hub ?

1 Like

I tried it on all usb Ports and two different Raspi 4 with no success, but an old raspi 3 (with raspios and pihole on it) recognized it immedeately correct.

pi@pihole:~ $ ls -l /dev/serial/by-id
total 0
lrwxrwxrwx 1 root root 13 Jun 1 15:25 usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_56942516afa4ed11be5beba32981d5c7-if00-port0 → …/…/ttyUSB0
pi@pihole:~ $ lsusb
Bus 001 Device 004: ID 10c4:ea60 Silicon Labs CP210x UART Bridge
Bus 001 Device 003: ID 0424:ec00 Microchip Technology, Inc. (formerly SMSC) SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Microchip Technology, Inc. (formerly SMSC) SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

thats the output on HASSOS
lrwxrwxrwx 1 root root 13 Jan 24 23:45 usb-1a86_USB_Serial-if00-port0 → …/…/ttyUSB0
~ # lsusb
Bus 003 Device 001: ID 1d6b:0002
Bus 002 Device 002: ID 174c:55aa
Bus 003 Device 003: ID 1a86:7523
Bus 001 Device 001: ID 1d6b:0002
Bus 001 Device 002: ID 2109:3431
Bus 002 Device 001: ID 1d6b:0003
Bus 003 Device 002: ID 1a40:0101

Running HA OS 12.3 ? downgrade to HA OS 12.2, could be the bug that serial devices are not (properly) recognised.

1 Like

Thank You for your help.
i flashed Z-Stack 20210708 coordinator fw to the dongle and now it is working.