My ‘Home’ App on iOS can’t find Homebridge

Hi, newbie here.

I’ve setup Home Assistant on a Raspberry Pi using Hassbian. Really at the very beginning of my journey into home automation so please be gentle.

Tried to add Homebridge. Using SSH I triggered the install and after a fast scroll of info on screen it advised me that Homebridge is running and it gives me an 8 digit code to use in the home app on iOS. This apparently adds Homebridge as a device under the’Home’ app (although I’m not sure why). Trouble is, when entering this code after selecting the ‘Don’t have a code or can’t scan’ line

it simply has a spinning ‘cog’ as though it’s searching for the device. Trouble is - it never finds it. Am I missing something? I’ve not added anything in the configuration.yaml folder. I’ve tried the integration of Homebridge twice now (from simply running the same command via ssh in terminal) with exactly the same outcome. Both times produced two different 8 digit codes. Both end up stuck searching for the ‘device’ in the ‘Home’ app. Help greatly appreciated (including what I then need to do to add devices thereafter)

If you are trying to use Homekit to control Home Assistant then I would recomend using Home assistant’s component.
Your current installation needs, I belive, further configuration. You need to make “config.json”
and enter your information there. Something like this.
“platforms”: [
“platform”: “HomeAssistant”,
“name”: “HomeAssistant”,
“host”: “”,
“password”: “yourapipassword”,
“supported_types”: [“automation”, “binary_sensor”, “climate”, “cover”, “device_tracker”, “fan”, “group”, “input_boolean”, “light”, “lock”, “media_player”, “remote”, “scene”, “script”, “sensor”, “switch”, “vacuum”],
“default_visibility”: “hidden”,
“logging”: true,
“verify_ssl”: true

look here
and here

Thanks so much for taking the time to reply. I’m a bit confused:

My original query related to the installation of homebridge. Through queries elsewhere I’ve basically been told that Homebridge is ‘difficult’ and that I should try using the ‘HomeKit’ component instead.Taking this on board I have installed this component (which was simply ‘home kit:’ and a self-created ‘code’ for HomeKit. I did this and, lo and behold, there was the Home Assistant tab in HomeKit. But that’s it - nothing else. None of my Yeelights.

Your response (i think) suggests using the HomeKit component too but the links you’ve attached seem to relate to the Homebridge component. Does the info on config.json relate to one or the other (HomeKit or Homebridge) or both? Also, again, newbie, so I have no idea where I’d need to type this in (if relating to the HomeKit component).

Someone else said that I simply needed to ‘unhide’ elements in the config and then manually hide the elements I didn’t want to appear in HomeKit. Again, I’m totally clueless as to how this is done or if it is needed. Any further help you could offer would be greatly appreciated. Thank you.


As a current Homebridge user and possible future Homekit component user, let me just jump in to try to clarify:

  • Homebridge is a NodeJS based solution which works without HomeAssistant and implies having other packages installed in the server; it has a plugin to expose Home Assistant entities to Apple HomeKit - more details here.

  • Homekit HA component is a recent component added to Home Assistant, which aims to allow doing the same as Homebridge and Homebridge-Homeassistant plugin do together today, but without the need of any additional packages (using Python only, as Home Assistant does), all within Home Assistant.

What is important is that Homekit HA component aims, but is still not yet there, it is a work in progress. If you read the component documentation, you’ll notice that lights are not even supported at the moment.

I hope I have been able to clarify.