My Home Assistant redirect leads to 404


I wanted to try out the new “My Home Assistant” feature but I can’t appear to get it working. If I enter my home assistant address - in my case “https://rutzberry” - it finds the server but it shows a 404 Not Found page. I have an NGINX proxy in front of home assistant (NGINX Proxy Manager), but even if I directly go through the naked port I get the same 404 message.

Did anyone have a similar issue and fixed it?


you can read this guide Reverse proxy using NGINX

Thanks for the guide, maybe to clarify: Everything in my setup is working as expected, I can reach my home assistant from both my local network and the internet. External things that require a connection (like Google Home) also work as expected.

It’s just the new “My Home Assistant” feature that was recently introduced that is not working for me. I’m running on the latest version (core-2021.3.2).

If you have default_config: disabled you need to add my: to your configuration to enable My Home Assistant integration


Thanks for the response! I think that might likely solve my issue. I scheduled a HA restart for tonight and will report whether it worked :slight_smile:

Forgot to reply :see_no_evil: The missing my: configuration key was the issue and it is now solved. :slight_smile:

Hi all, I also have this 404 issue.

I’m also a HA newbie so not sure what’s meant by Default_config being disabled or where to add my: so any detailed help appreciated.