My Hue lights have vanished

I noticed that my hue bulbs have disappeared from HA. I recently renamed a couple lights via the Hue app. Not sure if that’s the cause.

I tried deleting phue.conf and restarting. I got the configurator and everything appears to have completed correctly. I see an entry in phue.conf with my hub’s correct IP address.

I’ve tried using discovery (I usually have it turned off) and also with a “platform: hue” entry in my YAML.

No errors in homeassistant.log

But I have no light.huexxx entries at all.

Any thoughts?

Do you just have the one hub?

Yes. One hub and 4 bulbs.

Hmmmm. Could you post your hue light configuration?

  - platform: hue
    allow_unreachable: true
    filename: phue.conf

You know I’m really not sure what might be wrong, only think I can think to do is check the log by forcing info? Maybe then you can see what’s happening?

  default: warning
    homeassistant.components.hue: info

I’m not actually sure what the hue component should be written as could also be:

  default: warning
    homeassistant.components.light.hue: info


    homeassistant.components.light: info

I’d try to figure that out, might lead somewhere?

Hmm. No luck there, either. I only get some basic response from the Hue component

2017-10-20 08:56:55 INFO (Thread-7) [phue] Attempting to connect to the bridge...
2017-10-20 08:56:55 INFO (Thread-7) [phue] Using ip:
2017-10-20 08:56:55 INFO (Thread-7) [phue] Using username from config: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Nothing else. No errors.

OK. I’ve got them back now. I turned off the hub, turned it back on, then cycled each of my hue bulbs. At some point in that process, they reappeared. Weird.

Thanks for the advice and patience, though!