My Lovelace Plugins


#592

I tried and just used the latest script. But having the same issue:

Fri Jan 11 2019 13:35:59 GMT+0200 (Eastern European Standard Time)

Error running command: python /config/python_scripts/lovelace-gen.py, return code: 1

NoneType: None


#593

The latest version should never return 1.
What are you using to run it?

It’s not supposed to be in /config/python_scripts/ or to be run as a python_script.

… to be fair, that would make sense, though…


#594

I can see that in your script there isn’t return value 1.

I am using:

shell_command:
  lovelace_gen: 'python /config/python_scripts/lovelace-gen.py'

Your script is in my created folder /python_scripts.


#595

Ok. I managed to reproduce this on mobile.
I think I have fixed it in the latest card-tools update.


#596

Excellent!! Thank you so much for these!!


#597

I had the problem on Safari (Mac) and iOS (iPad and iPhone).

I installed the new version from GitHub and now it happens 1 out of 5 times (refreshing or reopening).

/local/card-tools.js?v=0.1.0:44:20 TypeError: null is not an object (near ‘…firstChild…’)

I then tried it in Chrome and there I’m always getting:

/local/card-tools.js?v=0.1.0:45:9 Uncaught TypeError: Cannot read property ‘dispatchEvent’ of null

I also tried:

javascript_version: es5, latest and auto. Nothing changed.

Not sure what I’m doing wrong but thanks for your help.


#598

Ok. Try now.


#599

Awesome!

As far as I can tell (in this short amount of time) it’s now working perfectly.

I will tell if it ever happens again.

Thank you a lot for helping :slight_smile:


#600

@thomasloven, should the card-tools update be shown in the custom_updater?


#601

browser-commander

Now here’s another one I’m really proud of, but it’s getting late over here, so for now I’ll just leave you with a link and a video showing the development version.

I’ll update this post when I’ve had some sleep.


#602

Regarding the folding entity card…

I configure this thus:

          - type: entities
            title: Folding Groups
            show_header_toggle: false
            entities:
              - type: custom:fold-entity-row
                head: group.all_automations
              - type: custom:fold-entity-row
                head: group.scenes

but then in Lovelace, (Storage Mode) after I paste this in raw config, it replaces it with this:

          - type: entities
            title: Folding Groups
            show_header_toggle: false
            entities:
              - type: 'custom:fold-entity-row'
                head: group.all_automations
                items:
                  - automation.beta_update_available
                  - automation.close_garage_and_set_alarm
                  - automation.coffee_maker_off
                  - automation.coffee_maker_on
                  - automation.deactivate_alarm_and_open_garage
                  - automation.home_and_away_off
                  - automation.home_and_away_on
                  - automation.lights_off_failsafe
                  - automation.lights_on_failsafe
                  - automation.make_snapshot_copy_backups_to_dropbox
                  - automation.power_state_sonoff_on_ha_start_up
                  - automation.sonoff_firmware_installed
                  - automation.system_runtime
                  - automation.tasmota_initial_setup_all_devices
                  - automation.toothbrush_off
                  - automation.toothbrush_on
                  - automation.turn_lounge_light_on_elevation_25deg_after_4pm
                  - automation.update_available
              - type: 'custom:fold-entity-row'
                head: group.scenes
                items:
                  - scene.bedtime
                  - scene.dining_daylight
                  - scene.dining_normal
                  - scene.dining_warm
                  - scene.lounge_100
                  - scene.lounge_daylight
                  - scene.lounge_movie
                  - scene.lounge_normal
                  - scene.lounge_warm
                  - scene.office_all
                  - scene.office_daylight
                  - scene.office_main
                  - scene.office_warm
                  - scene.desk_daylight
                  - scene.desk_normal
                  - scene.desk_warm

in the raw editor… so what happens if I add new automations or scenes? Is the list supposed to refresh?

Interestingly, if I open up the .storage/lovelace file in an editor it looks like this:

                                {
                                    "entities": [
                                        {
                                            "head": "group.all_automations",
                                            "type": "custom:fold-entity-row"
                                        },
                                        {
                                            "head": "group.scenes",
                                            "type": "custom:fold-entity-row"
                                        }
                                    ],
                                    "show_header_toggle": false,
                                    "title": "Folding Groups",
                                    "type": "entities"
                                }

If I use configureui it also shows all the individual entities.
I’m confused.
If I add a scene or automation, do I need to trigger Lovelace to refresh this card?


#603

Having the same here. The custom_updater is not showing the latest version of the card-tools.


#604

I manualy updated the card-tools and changed the version to 6ce5d0, which should be the latest version.
Now the updater shows an update to the old version number.
So i think everything with the updater is ok, but it gets the old version number.


#605

After change in lovelace-gen.py in GitHub, that shows how to generate lovelace-gen.log. I found that my one of my lovelace.yaml has some kind of error. After not including that yaml file it works just perfect. I need to look what is wrong in that file.


#606

Mine shows 0a97de for both but I see the latest version in github is what you said. Maybe the custom card tracker is getting the wrong version number? I only added the card yesterday… (I’ll check I really have the latest card tomorrow…)


#607

YOU CAN BE!!
Awesome!
For those who watch the video:
Event type should be browser_command, not browser_cmd.


#608

The custom_updater is working again, I’ve got an update of card-tools. No need to change anything.


#609

Huh. I didn’t know the lovelace editor did that… neat I guess, but I should fix the plugin so that it doesn’t.
Expect an update soon.

Don’t worry, however. As long as head: is a group, whatever is in items: is actually ignored. It will always take what’s currently in the group. In fact, it will probably update the configuration too.


#610

I just got a notice to update to 6ce5d0 so must have been a glitch yesterday…


#611

@thomasloven i’m following your cards for a while. just wanted to say: awesome work you’re doing here. thanks a lot!